Re-adding homely (not a typo) devices


I recently got a Homey Pro 2023, and installed the homely app to link it up with the sensors connected to the alarm system.

After a few days, I noticed the sensors had not updated state to homey for some reason… So I removed a device with the intent to add it back again.

But now I was unable to connect it, figured it might be the app for some reason, reinstalled it, no luck. Now no devices could be connected.

Since it was quite a new homey, and I had not made many flows etc. I figured I’d just try resetting the Homey Pro to factory settings and start again.

Still no success. Any idea how I could solve this?

Hi there, welcome,

Can you tell us which steps you took, and which error messages you got?
Did you try on both apps? Sometimes things work only when using the web app, or only by using the mobile app.


Thank you.

I removed the device from Homey using the mobile app, within the device settings.

I then went to add new device, picked the homely app, logged in with my credentials, and it shows “new devices found, select ones to add”, but it doesn’t show in the list, it’s just empty.

Aaand just as I went through the adding process to make sure I give you the right information - it worked. Typical, haha… I guess it just needed time, or the homely company did something, as I emailed them on Saturday.

So yeah… Hm. This is awkward. I guess it’s resolved.

1 Like

I have experienced this multiple times. It usually solves it by choosing one device and “Repair”. Then just log in with Homely credentials.

After some time, all sensors will work. (You should only have to log in to one of them).

It would be better with a API key or similar, so we don’t get this sudden logged out condition.