Quality of Homey Support - Not Impressed!

Having had my Homey for a few months now I use it for general home automation mainly turning on lights and integrating with heating.

One main critical thing that I purchased Homey for was for it to work with my Aeotec gen 5 Garage Door controller.

I did try a Vera hub with the garage and it worked perfectly but Vera has no integration with my Hive home heating and that is one main reason why I went over to Homey.

My main reason for wanting garage door control was I kept forgetting to close the garage and set up a flow to do this automatically after a period of time.

Although Homey on the old v1.5 release was a bit of a pain to set up with the garage door controller, due to the open/closed being the wrong way round, I set up the flow to compensate for this, it did work.

I previously also raised a support case as Homey refuses to see more than one heating thermostat for Hive and i have one upstairs and one downstairs in my house. I was told that this was not a priority at the time and it still has not been fixed.

Since updating to v2 software, Homey refuses to send any commands to my garage door controller, so may main reason for purchasing it does not work at all.

Having raised a further support ticket and send requested diagnostic information to Homey Support for this issue, I get a response that says they will pass on to the app developer, which means I may get it fixed at some point if at all.

While I understand that any device manufacturer is dependant on app developers that support their product, for what is sold as a consumer product, this is unacceptable.

If I bought a TV from a shop and the manufacturer of the product bricked a significant functional part of the device with a software update and could not fix it, I would expect to take it back and get a refund.

When Homey updated their software to v2 beta, I did not upgrade as I wanted a release and stable platform and it seems that if the released v2 also breaks stuff, I have wasted my time.

Homey is far from a consumer product and I am now in the position for reviewing if I continue with it or just throw in the towel and forget home automation :frowning_face::frowning_face::frowning_face:

1 Like

With all respect, I’m not sure what you hope to achieve by posting this on the forum.

I understand that you’re frustrated that the product doesn’t work anymore, but I believe Athom’s support team did everything in their power. They tried to help you fix the problem, and once they realised it required a software change, they contacted the person capable of doing this (the developer of the Aeotec app).

Now whether or not you think Homey’s return policy is fair is a different question. That I feel is worth argueing about, because I indeed think it should be fair that you can return Homey in an appropriate time-frame since purchase if a core feature is lost.

Which is Athom…

1 Like

Athom support’s team is not in charge of developing the app. Sure, Athom as a company is in charge, but the support team did what the support team could do.

Telling someone that they will pass on the issue to “the developer of the app”, when that developer is probably sitting right across from the person handing the support question, is a pretty minimal effort. At least give your customer an indication about how long it will take to get it fixed.


But that’s not my point. My point is that the support team cannot possibly do anything else. The issue won’t be fixed faster if they give a timeframe to the customer, which is likely to be wholly unreliable anyways (assuming that indeed the developer indeed is in office today etc)

That is something that Athom should get right indeed but at the moment there is no such thing as a SLA or something similar. For most consumer products an SLA is not in place. So the response ‘we will forward it to the developer’ is similar to 'we will forward it to technical support and let you know when we have more information.

Key thing is here. How long ago did you @jpmbosco send that e-mail to support about v2.0 and the app not functioning? Would you rather have a standard automated response telling you it will take at least 30 days to respond? (for instance)

Question is also if it’s one device or if it’s really an issue in the app…

Thanks all for your responses, I do take on board the fact that as such Homey Support do respond usually within a couple of days and it is not the speed of response I am a bit dismayed with.
My main objection is that as I stated, I did not implement a beta update but waited to allow what I thought was a stable version to be released.

Understand that Homey are somewhat at the mercy of the developers but I would expect that Homey at least ask the more well known smart device suppliers to test against their products when a new major release is planned.

On the issue of consumer rights, then I expect the main device manufacturer not to brick my functionality with major updates or at least tell me what has been tested to work with this update and warn me that any non tested app/device was implemented at my own risk.

Well, in this case Athom is the developer and they stated all Athom-apps would keep working. That’s why I’m wondering if this is an issue in the app or if something is wrong with the device?

1 Like

@jpmbosco had a working Homey, installed a firmware upgrade about which Athom states is stable, and now his Homey doesn’t work properly anymore (w.r.t. this particular device). I wonder if that’s ground to either return the device to Athom for a full refund (because of non-conformity), or demand that it gets restored to the previous firmware version.

The Garage door opener consists of 2 parts, the main switch and a position sensor, which detects if the door is open or closed. I know that the sensor is sending position info back to homey as I have made a flow to announce door open and flash the LED ring red and another to announce door closed and flash the ring green and this works perfectly every time I open or close the door with my garage key fob.
What does not work is the open or close command from Homey as it should close the door after a set period. Even using the manual action on the mobile app only works every few attempts and I have tried both Android and IOS.

I know it is difficult to test but did you also check other influences as other z-wave traffic, distance between Homey and the garage door controller etc.
The fact some issues arise or get noticed when a major change happens not always make them related.

Imho not Homey itself is a difficult product but the related technologies like different wireless technologies and mesh protocols and many different brands you can connect can make troubleshooting difficult.

Although Athom may come up with a solution, imo the community is also willing to help if you ask here on the forum or on slack.
For many users that works faster as the resources at Athom are limited compared by the daily activity from the community.

Before leaving homey, I had an issue with athoms sartano app after the 2.0 update I contacted support and got an answer, that they were not focusing on that app right now…

Which is fine I guess. But… Meh…

Yes I understand and this seems a friendly community. As far as other external influencing factors are concerned, I have not changed anything at all with either set up or devices either before the upgrade to v2. On v1.5 my garage door opener worked OK bu now is broken.

But to come back on troubleshooting, did you try to bring them closer and see if it works then? Or investigate in the z-wave logs to see what is happening? Maybe even eliminate possible disturbances of other z-wave devices or flows by unplugging or disabling other devices, disabling apps or flows?
It could still be something else as cause even already a potential problem in 1.5.x but visible now with 2.0

I am not yet convinced it is an issue in homey or in the app you use.
By eliminating you can drop down to the root cause.

1 Like

Hi Dijker, I am using the garage remote with a Aeotec range extender and I have taken both next to the Homey and un paired and re paired multiple times. This as well as uninstalling the app on Homey, restarting homey, restarting z-wave. I have sent a diag to Homey as well. I have not tried disabling other devices or disabling flows yet, I can do that. Also I am reasonably tech savvy but not a programmer, how do I look at the z-wave logs?


Thanks bvdbos, will give it a go.

Have taken a log but not sure how to interpret it or where to post it, could someone assist please?
Also I have noticed that if I send the close or open command 2 x in quick succession, the door will open/close.