Problems directly associating Heatit Z-push button 2 with Fibaro Dimmer 2

Hi all,

I am having serious problems associating Heatit Z-push button 2 ( with Fibaro Dimmer 2 (

Both devices are added to Homey as secure.

The Fibaro has nodeid 16.

I enter 16 in the group association (group 2) of the heatit device, wake up the device and hit save. Homey responds that settings have been saved.

When I press the I and/or O buttons of the Heatit device nothing happens. Tha association seemingly has not been created. Anyone had the same problem and found a solution? Is there any way to debug this - can I somehow see what messages/signals are being sent from the Heatit device when I press the different buttons? Or can I load/reload the config from the Heatit device to double check that the settings (group 2) are stored there? (Homey reports Group 2 with nodeid 16).

I have also tried with nodeid 16.1 since the Fibaro has 2 inputs but with the same result (not able to turn on/off the Fibaro)

Any help would be greatly appreciated.


@henrikln did you follow the guide to create the associations as described in the FAQ section of the Heatit app topic?

As mentioned there, the timing is quite tricky. Homey will always indicate that the associations are saved, which doesn’t mean that the associations are actually received by the Z-push device.

I’ve done it in that order but I was unaware of the logging functionality on so I will retry this evening whilst logging is on. I’ll revert back with the solution or if the problem persists posting the log. Any settings in the devices that can cause problems? (other than making sure both are added secure - which they are).



Tried all the steps in the FAQ while having logging on. No log entry for the push button coming online or becoming offline turns up in the log when I press I and O for 3 seconds.

Here are the log entries following pressing I and O to wake up the push button:

|2019-12-18T07:30:51.691Z|Node[27]: Received application command for COMMAND_CLASS_SECURITY, data: 0x40|
| --- | --- |
|2019-12-18T07:30:51.691Z|Node[27]: [COMMAND_CLASS_SECURITY] {}|
|2019-12-18T07:30:51.692Z|Node[27]: [COMMAND_CLASS_SECURITY] [SECURITY_NONCE_REPORT] {"type":"Buffer","data":[37,187,178,6,84,251,224,212]}|
|2019-12-18T07:30:51.692Z|Node[27]: sendData to COMMAND_CLASS_SECURITY, params 0x8025bbb20654fbe0d4|
|2019-12-18T07:30:51.695Z|Command[4781] start: sendData|
|2019-12-18T07:30:51.696Z|ProcessSendData[4762]: To node: 27 with data: 0x988025bbb20654fbe0d4 and txOptions: AUTO_ROUTE,EXPLORE|
|2019-12-18T07:30:51.719Z|Command[4781] end: sendData|

I tried to save the settings nevertheless and afterwards when I press the I button on the push button switch the following log entries show up:

|2019-12-18T07:34:08.437Z|Node[27]: Received application command for COMMAND_CLASS_SECURITY, data: 0x40|
| --- | --- |
|2019-12-18T07:34:08.438Z|Node[27]: [COMMAND_CLASS_SECURITY] {}|
|2019-12-18T07:34:08.438Z|Node[27]: [COMMAND_CLASS_SECURITY] [SECURITY_NONCE_REPORT] {"type":"Buffer","data":[46,160,234,117,104,5,208,201]}|
|2019-12-18T07:34:08.438Z|Node[27]: sendData to COMMAND_CLASS_SECURITY, params 0x802ea0ea756805d0c9|
|2019-12-18T07:34:08.440Z|Command[4798] start: sendData|
|2019-12-18T07:34:08.440Z|ProcessSendData[4775]: To node: 27 with data: 0x98802ea0ea756805d0c9 and txOptions: AUTO_ROUTE,EXPLORE|
|2019-12-18T07:34:08.462Z|Command[4798] end: sendData|
|2019-12-18T07:34:08.494Z|Node[27]: Received application command for COMMAND_CLASS_SECURITY, data: 0x81983c97d097f5067ceb0f4732ec282e010efcb12fee40ce|
|2019-12-18T07:34:08.495Z|Node[27]: [COMMAND_CLASS_SECURITY] {"Initialization Vector byte":{"type":"Buffer","data":[152,60,151,208,151,245,6,124]},"Properties1 (Raw)":{"type":"Buffer","data":[235]},"Properties1":{"Sequence Counter":11,"Sequenced":false,"Second Frame":true},"Command byte":{"type":"Buffer","data":[15,71,50,236,40]},"Receivers nonce Identifier (Raw)":{"type":"Buffer","data":[46]},"Receivers nonce Identifier":46,"Message Authentication Code byte":{"type":"Buffer","data":[1,14,252,177,47,238,64,206]}}|
|2019-12-18T07:34:08.506Z|Node[27]: Decapsulated frame from COMMAND_CLASS_SECURITY to COMMAND_CLASS_CENTRAL_SCENE, data 0x03728001|
|2019-12-18T07:34:08.507Z|Node[27]: [COMMAND_CLASS_CENTRAL_SCENE] {"Sequence Number (Raw)":{"type":"Buffer","data":[114]},"Sequence Number":114,"Properties1 (Raw)":{"type":"Buffer","data":[128]},"Properties1":{"Slow Refresh":true,"Key Attributes":"Key Pressed 1 time"},"Scene Number (Raw)":{"type":"Buffer","data":[1]},"Scene Number":1}|

Any suggestions?

OK, did you remove the association pressed save and then followed the guide referenced above?

Homey is stubborn… and pressing save will not trigger any action, since Homey thinks the state of the association did not change.

So please remove the association, press save and then follow the guide as referenced.

I did remove it and press save. I also tried to change it to no association, save it, associate with a different node and save it, and then associate it with the correct node and save it. I’ll try again right away to remove it and paste the whole log.

Please paste the whole log and check if the ASSOCIATION_SET command is send after the scene controller is marked online and before it is marked offline.

I got it to work now. It seems I have to press I and O for more than 3 seconds to send wake up. Thanks for helping out!

One more questions @TedTolboom; will you post an update to the Z Wave app supporting 4 button switches? For the most part I have 4 button switches. And meanwhile, can I add them as 8 button switches and use groups 2-5 from this to associate the right lights?


I was expecting to receive the Z-push button 4 from Heatit several weeks ago to complete the implementation (get to know the correct Z-wave ID’s)… but I did not yet receive it. Just send them a reminder.

If you could add the Z-push as generic device to Homey and post a screenshot of the ID’s mentioned in the advanced settings, I could complete the implementation in parallel.

Great, the screenshots are attached here. Thanks!


They are also marketed as Namron buttons, where all IDs and settings are the same except for Produsent-ID (Manufacturer-ID) where Namron has 816.

I had also problems with the Dimmer 2 and Associations. Even when both devices are included secure.
After include the Dimmer 2 unsecured everything works like expected.