Homey Community Forum

Problem with the Philips dimmer switch

Are there anyone else here that are using, and experiencing similar probles with the switch?
May be once every week i have to restart my homey due to that the switch gets unresponsive and just blinks red with every push of a button.
I have two of them, and its the same with both.
I have them connected via the “Philips hue Zigbee” app.

Same here. Check out Github, this is a known problem but it has not been solved for a long time already.
I need to re-include the dimmers to get them working for only a few hours :frowning:

I cannot offer any direct help, only that the dimmer works fine here, I am interessed in the flows you use though, maybe I can optimize mine

Hm, ill do that, thx.
Compared to you i am lucky then! hope it gets sorted out, really like this dimmer switch,

The one by my frontdoor is just used to turn on a few lights.
One press on button 1 and five lights goes on, if a press that button again, a sixt lamp toggles on/off.
If I press 0 once, I turn one lamp off, if i press it twice i turn everything off.

The one in my kitchen kontroll 3 lamps and sonos.
one press on button 1 activates my spotlight over the sink. if i press it again it toggles my lamp over the dinner table + turns on sonos. if I press button 0 it turns sonos off and if i press it again it turns the kitchen lights off.
the dimmer buttons adjust the volume on sonos.

I like the setup, works for me. good or bad, you tell me :slight_smile:

Yes it never crossed my mind to use the 0 for different uses,! Thx :pray:

1 Like

Can you share how did you setup multiple presses on Hue dimmer swtich? I know Hue hub has multiple presses of ON for different scenes but there isn’t support in Homey. I would like also do use dimming up/down to control volume level of Sonos speakers. Do you have suggestions? Thanks!

1 Like

You are limited to these steps of activation, not like the hue a guess.
could be better ways of doing it, but this suits my setup :slight_smile:

Regarding the Sonos volume, you have to create a variable, using Logic, or better logic. and use that with the “set volume” tag for the speeker.

1 Like

Thanks A-A. In the meantime I figured out Flow with Better Logic, maybe is complicated but “Logic” is hard for me but Better Logic is much easier and this was my workaround.

I edited the post so it wont confuse others.

Dont really see what you did there, :slight_smile: but if it works for you thats great!
its real nice not having to use your phone everytime you want to change the volume.
With my flows, each press of the volume button, takes the present volume of the speeker (via the “Tag”) and then adds/reduct 0.02 to it. (via the “calculate a numerical value”).

This is embarrassing, I just realized how complicated mine is. I figured how to use Logic and have set up for volume to go to “calculate value” but it jumps allover if i start from 0 then it gos ok like 0.05, 0.10, 0.15 but it also jumps allover values goes to 0.95 then to 0.45, 0.15, 0.70 etc… same happens with volume down. Why do you thinks it jumps??

I had this phenomena too. For me, it was that i used the wrong tag on the Sonos card.
When i changed it to the value i made with Logic, it worked great. (I used the speekers own volume tag)
{{ Set volume+0.02 }} This is what i wrote in the “calculate a value”-card. by some reason it is important with the spaces (and non-spaces)
This any help to you?

I did put correct Logic (just used .05) but here is a screenshot with the issue. Values are erratic and unusable https://cl.ly/15594b8936ce
And settings:

I am far from an expert at this, but by the look of your screenshot, the calculation in When looks a bit off. (I have just learnt by trial and error.)
check that yours looks like this --> {{ Set volume+0.02 }} (space beween the brackets, and no space before or after the “+”)

Just rememberd something else, I have added a 1s delay to the Set volume card. on both flows (volume up and down) try that aswell

Just to be clear, the screen I submited earlier, is just for volume Up.
this is for volume down:

1 Like

This was the solution! Delay was needed for Homey to calculate correct volume level.
Thank you for help! Now I have to figure out why it doesn’t work when 3 speakers are grouped