Problem with adding devices in Homekit

Today i have added some Hue devices which works perfectly. Like always i like to add them to Homekit so they will appear on my iPhone.
Now i have this problem. The app doesn’t show anything, i am unable to add or remove devices.


Offcourse i have rebooted Homey. What can i do more except removing and adding the app again?


Removing and adding the app results in a not working homekit on my iPhone and the same problem on Homey.

-Edit 2-

I tried to remove Homekit and i installed Homeykit, then i have the same problem…

Thats a JS error, can you try running app from chrome and see if you get a more detail error?

Chrome shows the same page, it’s not possible to click on anything within Homekit on Homey.
I used the Homey desktop app, firefox and chrome.

Now it’s even not possible to readd Homey to Homekit (666-66-666) Homey is not present within the Homekit app on iPhone.

Does the console in the developer tools tab have any further information ?

Yes, and i have solved the problem.

My PiHole was blocking

Laden voor het met bron ‘’ is mislukt. settings:4:1
ReferenceError: Vue is not defined[Meer info] settings:63:7
self-hosted:972:17 Homey.prototype._loadI18n/</</<
self-hosted:972:17 t

Only problem now is adding Homey to Homekit on my phone, Homekit doesn’t find Homey.

Make sure that both your phone and Homey are on the same network. It’s a bit of a trial-and-error process in my experience, sometimes it works when you toggle your phone’s airplane mode, sometimes it works by restarting the HomeKit app on Homey, etc.

I am on the same wifi and accesspoint with my iPhone and there is no way i can add or find Homey. I tried reinstall, restart, reboot homey, reboot phone, airplane mode…
Is there another thing i forget about?

Nothing I can think of. HomeKit discovery works using mDNS over IP multicast, so that needs to work, but typically, it does.

Which Homekit app are you using? The one called “HomeKit” or the one called “HomeyKit”?

I’m using the Homekit app. In Homekit on my iPhone i can find my Hue bridge so i assume that multicast is working.

Solution was to delete the whole ‘Woning’ in Homekit, Immediately i found my Homey and i can add my devices.