Cannot add HUE wall switch modules in my Homey-Pro 2023

On my Homey Pro 2023 I was able to add all my HUE bulbs and swiches/remotes with no effort. Now I added two new HUE wall switch modules (the ones you can build in) but my Homey Pro does not see them. I cannot figgure out why and how to solve it.

All my HUE stuff is also fuctional in the original HUE-app, including the HUE wall switch modules. So I can use them with the original HUE-app.

I upgraded the HUE-app in the Homey Pro to the beta-version 6.0.0. That dit not solve it.

Anyone facing the same issue? Is there a soultion?

Hi Bas, same problem here. The Hue wall switch can be connected and configured in the Hue app with bridge, but is not recognized bij Homey Pro 2023.

I’m new with Homey, but please let me know if anyone has a solution.

1 Like

seems to be resolved with

6.1.1 (7. Feb. 2024)
Added device ID to Hue Module.

Unfortunately, still the Hue Wall Switch Module cannot be added to Homey Pro.

Strange, I added three wall switch modules to my hue app this weekend, and they showed up fine in my Homey Pro.

Thanks, which app did you use? I use the standard Hue app in my Homey Pro 2023.

Yeah, just the regular Philips Hue app (version 5.9.3 to be exact). Added a device in Homey, selected Philips Hue, selected the ‘Module’ device, and it just found all of my installed modules.

Thanks. I tried that before using the Hue bridge and that didn’t work. So I tried the Homey Pro Hue app without bridge and that one doesn’t show find the Switch Module. I tried all three Switch Modules I have but no luck.
On GitHub someone advices to press the reset button every second and that allowed to at least see the general Zigbee device but no more details. It is registered as RDM004.

Hmm, mine identify as RDM001… I’m seeing some discussions about the 004 being a newer version (although I bought mine a week or so ago), and also about that 004 not being recognized on other platforms as well…

I think the changelog entry stating ‘Added device ID to Hue Module’ is more about the settings of the device showing the device id (RDM001) instead of not showing anything rather than also supporting the newer RDM004 model.

Is there anybody that has an RDM004 model wall switch working? I still need to purchase a bunch of them and I’m hesitant if that newer model is really not yet supported.

I have exactly the same problem with the RDM004 version. Using the app without the hue bridge, the device is recognized as general Device. Yesterday I bought a hue bridge which did solve the problem with my outdoor sensor but not the wall switch. Homey Pro doesn’t find the device. The device works in the hue app. Also related Google and Apple apps do recognize the outdoor sensor but fail to recognize this wall switch. It seems that the device is invisible for external apps.

Maybe it is just a matter of the software currently only checking the RDM001 identifier and not the RDM004 identifier, which should (hopefully) be easily fixable by either the creators of the Hue app, or the creators of the Hue without Bridge app.

I see that the creator of the Hue without Bridge is already working on adding the RDM004 (see Support Hue wall switch · Issue #547 · JohanBendz/ · GitHub), but seems to be needing some additional info or something.

I have the same problem with the new Hue wall switch modules, they connected well to the Philips Hue bridge, but then could not be added to the Homey Pro 2023. I was with Hue app version 5.9.3 in my Homey pro.
Then I installed Hue app version 6.1.2 (test version, experimental) and is was working, I could connect them to the Homey and they were working fine.
However, an other problem appeared. I have RobbSmart double switches connected on the Hue bridge, and then added to Homey Pro 2023, but after installing version 6.1.2, the second contact of the double switches disappeared from these switches! App version 6.1.3 experimental appeared, and it remained the same, Hue wall modules working well in Homey, but the RobbSmart double switches channel 2 was still missing. One more problem was that I installed some more RobbSmart switches, and they did not appear in Homey. Therefor I rolled back to the standard app version 9.1.3, and I am waiting for the next update. I need to nu y some more RobbSmart switches and also some more Hue wall switch modules, but I am now waiting what will happen, if both will work, otherwise I have to find alternative for one of them.

I just saw that the TEST version of the Hue without Bridge app (Philips Hue, without the bridge | Homey) has been updated and should have support for the RDM004.

Anybody try it yet?

1 Like

I tried it and it seems to work now. The Switch Module was added to the of devices list and paired easily. Thanks everybody involved. This was key to setting up Philips Hue, without a bridge, with Homey for my new house.

1 Like