Problem controlling roller blinds with scene from Fibaro dimmer 2

I was unsure of which category to put this post, but I decided on this one as I’m not sure where the problem is.

Products involved:
Fibaro FGD-212 (Dimmer 2)
Ikea Trådfri Fyrtur Roller blind

I want to use S2 on the dimmer to control the roller blinds. I have enabled “scene activation” and created two simple flows:

When: “Dimmer 2 scene (momentary)” - “Pressed right (S2) 1x”
Then: “Roller blind” - “Adjust position to 0%”


When: “Dimmer 2 scene (momentary)” - “Pressed right (S2) 2x”
Then: “Roller blind” - “Adjust position to 100%”

When I test the flow from the app, it works just fine. Controlling the blind in other, automated flows also works fine.
However, when I trigger the flow via S2 on the fibaro, the blinds only runs for a second or two, before it stops.

It seems like the flow itself stops running or something?
Based on that theory, I tried to make a workaround by making a separate flow that open av closes the blind, and then use the flow activated on the fibaro to run the flow for the blind. The result is exactly the same. -It works when testing from app, but fails when activated from the switch.

Any tips or ideas?

Hi, You need to enable “Scene activation” under advanced settings for the “Dimmer 2”. I hope this resolves your issue.

Hi Awangens,
Thanks for stepping in. Unfortunately this does not help. If this was the case, there would be no reaction from pressing the scene button at all.

What I’ve found, without updating this post, is that the flows seems to work fine if I set the blinds to a position between 0% and 100%. So I have set the flows to adjust blinds position to 96% for open, and 2% to close, and this works fine.

My conclusion has to be that this is a software related error, but as I’ve found a workaround that works for me, I haven’t bother to look further into it.

I have exactly the same problem, but with rubato double smart relay. I want S1 to start a flow that opens four FYRTUR, and S2 to close them. It is really unreliable. I have tried pressed X1, Hold and Hold release.

Sometimes it works, sometimes not. I tried changing the percentages, but it didn’t solve the problem.

Is this just a FYRTUR thing or are people having trouble triggering other flows with the Fibaros?

I use Fibaro Walli Switch, Walli Dimmer and Walli Controller with Scene Activation and have no problems with this.
I also use IKEA Kadrilj blinds with no problems, but not in combination with the mentioned Fibaro devices.


So I tested it myself:
– Double Klick on Bottom Switch of a Walli Switch: Both Kadrilj close to 0 % immediately
– Double Klick on Top Switch of a Walli Switch: Both Kadrilj open to 100 % immediately

I think I have found the solution. The settings in the fibaro may be the porblem. I have a flow to open and a flow to close the curtains. They work fine if I test them form the flow editor, but very weirdly when I press the fiber buttons. Check out this thread:

Basically paste in the following in the raw configuration and save it:

If you want to try out the raw configuration (to “resend” it), you can add 28,1,15;29,1,15

I’m so relieved that this problem I solved!

This is what @Awangens meant:

Don’t own a Double Smart Relay nor a Dimmer 2, but with a Walli Switch and Dimmer for example you don’t need to do a raw configuration, because for „Scene activation“ there are advanced parameter:

But good that it works now. :+1:t3:

Well I’ve checked it out further, the solution with there raw configuration solved the problem with my dual smart module, but not with my fiber dimmer2.
On the dual smart module I use the switch only as a remote, it’s not connected to any lights. When I entered the raw parameters it started working.
I also have a dimer2, where I want to use double click to start a flow. This is still not woking. I have clicked and unclicked the parameter to allow starting scenes, but it still does not work.

As I mentioned before, I also don’t own a Dimmer 2. But according the manual it seems to be a bit different to the Smart Relay:

So if you need only the 2 x click (for S1 input), try this these raw configuration datas: 28,1,14

This won’t work, the dimmer 2 can only enable (28,1,1) or disable (28,1,0) the scene activation.
The values you are showing are the values the dimmer 2 sends to Homey on said button presses.

1 Like

Ok, didn’t know that. Thanks for clarification