Popp keypad not working with v2.0.10

I just received my Popp keypad and added it into Homey with help of the v2.0.10 popp app.
That part went very smothly…

Then, after adding a pincode for user 1, I wanted to test a flow.
I created a very simple flow:
When: “A user verified itself”
Then: Mobile: Send User verified to User

Adding the correct pincode give my green light in the actual Popp keypad but the flow is not triggered. Do anyone know what problem can be?

I’m finding the same thing. Did you get this resolved?

Actually I just resolved this. Turns out the little magnet inside the back cover had moved and was preventing the tamper alarm from being deactivated.

Have had the same problem for months, also before upgrading, the magnet is in place, still the tamper alarm does not deactivate. Therefore I tried with the tamper alarm on in the card “and”, but flow still does not trigger.

The solution for me was to upgrade to the beta version (now stable 2.0.12) at that time. After that both the tamper alarm went away and the flows started to work.

However, sometimes (not often) the keypad is not properly functional. When entering the correct code, it does not disarm the alarm. I have done a lot of trouble shooting and these are propably some of the reasons:

  1. Z-wave NW problem (Solution: Move keypad closer to Homey + adding Z-wave range extender)
  2. Memory problem in Homey (Solution: Restart Homey a couple of times each week)
  3. Keypad firmware version (No solution yet)
    See: Popp keypad firmware version

Regarding issue 3 above I have contacted Aeotec support and they told me that the only firmware version out there should be 1.0.8.
However, my Popp keypad has firmware version 263, which is 107 in hex. So, I’m trying to sort out with Aeotec helpdesk how to upgrade to 1.0.8 which should be 264 in decimal.
Which firmware version have you on your Popp keypad?

Well, #Mapulu did mention core as the probably source of problems. My firmware is 264, 1.0.8. My Homey popp app version is 2.1.0.

The Popp app version 2.1.0 is the beta version. Isn’t it better if you try the stable version (2.0.12) ?
It works fine for me, despite the intermittent problem.

Every version has been tried, same results! Works sometimes :slight_smile:

What do you mean that it works sometimes?
Do you mean that the tamper alarm only deativates sometimes?

Sorry to wake up an old feed… Is the keypad working well now without any issues?

Yes it works perfectly. The solution was to move Homey closer to the keypad since the Z-wave signals was not strong enough.