Aeotec Door/Window Sensor Gen5

This device is available to install but not working properly when I install. I have four of them and all behave the same way. Tamper alarm indication all time and contact alarm not reacting at all. Any ideas how to get this working with Homey?

I bought and installed one these yesterday and it works fine. However, I noted one thing. If you use the sticky pads to mount it, the pads are thicker than the distance from the surface to the tamper switch. I simply slipped a small piece of metal between the two and problem solve.

No difference for me if tamper switch has good connection, e g not mounted and manually pressed down. I still get tamper alarm flashing all time, and no reaction on contact alarm at all.

However, if I uninstall the devices and disable/uninstall the Aeotec app, and then install the door sensirs as a ”Basic Z-Wave Device”, the contact alarm reacts. I might use them like this for now.

Is it possible you paired too far from homey initially

I have tried to install the Aeotec device next to Homey, but same issue.

Any update re the tamper switches being fixed on these v5?