Official IKEA Trådfri vs IKEA Trådfri Gatway App

Because removing a device changes the network, and you never know in what way it changes. If you only have 20 devices in total it should work, but I would a least do a full reboot of Homey after removing a device to make sure it’s properly removed from any internal tables.

That’s bad marketing. Athom’d rather let people find out themselves that Homey is limited in that respect.

If you’re still using the original Athom power supply for Homey, change it for something else. 5V and 2A minimum of a decent brand should work. The original power supply is crap and can cause random issues.

No, you can’t force that. You can try pairing the device closer to the router and hope it uses the router, but no guarantees. With the v5 firmware, you still can’t force a device to use a router but according to lots of users that are running it, the mesh network is much better (if it works, some people had to do a full Zigbee reset after upgrading to v5 to get their Zigbee working properly).

I’ll try removing a few more and see what happens… would rather wait full the verified release given the issues i’ve seen with RCs in the past

Do all Zigbee controllers have the 20 device limit? Or just a Homey issue?

Ah, I changed the power supply long ago as running of a UPS

The Zigbee chip that Homey uses is rather outdated (originally from 2009 I think). Since then, plenty of alternatives have become available that aren’t as limited.

1 Like

Hmm… thanks. Another nail in the coffin perhaps…

I have now removed 2 devices, rebooted and still unable to add the signal repeater… I’ve tried both directly next to Homey and directly next to one of the router devices with nothing being picked up at all as far as I can see…
Don’t really know what to do now…

PTP maybe?

Done a few times sadly. Might be worth another one tho

Tried again since I’d deleted the devices but nothing still :frowning:

EDIT. Given up… wanted to rule out the IKEA devices and just managed to reconnect them back to the gateway again… Will leave it like that

Seems to be broken as per gateway update version 1.15.34 (30th june 2021]

1 Like

New app version v0.1.5 is published and it seems that the bug is fixed (-> Thread).


Yes confirmed it is fixed v0.1.5

So, at v 1.8.4 and 7.1.1-rc 1 and still they wont work after 7.1v homey came. Any solutions?? Just ditch the homey ???

In my previous Homey setup I ran into trouble because of too many connected zigbee (tradri gu10 spotlight) devices. Homey adviced me to remove these from the Homey network and connect trought the ikea gateway.
I have not fully setup this since its a nuisance to manualy remove, pair and reinstall all my spotlights.

Question: if I install the UN-official gateway app, will this prevent me from running into my previous problems of too many connected zigbee devices?

The IKEA gateway has more capacity, either 50 or 100 light bulbs (internet sources are unclear). However, the IKEA gateway app for Homey doesn’t support other types of devices, like remotes or sensors.

I actually have decided to use a mix of both.
Some TRÅDFRI devices i connect via the gateway some directly to homey.
It strengthens the homey zigbee network in my house, as the TRÅDFRI devices also work as a router and at the same time i’m not completely in the dark if for whatever reason homey crashes.

1 Like

so far, I only have one IKEA socket and one wallswitch - together coupled to an IKEA TRÅDFRI (is it “hub” or “gateway” ? ) . using this one socket through Homey is very inreliable. When I go to ;
apps → configure → (change nothing) → save

it will work for 2 or 3 times and then well, every sometimes only.

the ikea is attached to my router with a fixed cable - if only the atom gods were that QOS aware… but still I do not think the (wifi)ethernet connection in between them is the issue.

what could be?

then; I understand that inputs are not communicated by IKEA, but outputs are.

the weird thing of the process with IKEA is that you need to “learn” a button to a socket/light and then “learn” the button to the gateway. So the button tells the gateway that there is another device. this is all so weird to me. yet I can connect the socket/light directly to homey too?
(wich I probably will not do, as I’m only running into the max 20 devices much sooner then) .


currently already the Fyrtur inside and works perfectly.
However looking into this model TREDANSEN Verduisterend plisségordijn, koordloos/op batterijen wit, 140x195 cm - IKEA België
Seeing that it’s currently not possible adding this one but possibly it will work as well ? Any experience with this from someone ?
Or alternatively, will this one be added as standalone device in the near future ?

Thanks already !

I have recently bought “Tredansen” but homey do not recognize it. Hopefully they will add it soon!

If you want support for the app without the hub, better request it @ Athom, the developer:

Thanks for your reply ! Hope they add it soon for you, I sticked with the Fyrdur to be on the safe side.

Me too :frowning: