Notify when sensors are offline/missing?

Is there a way to detect if a device is missing?

I have 30 zigbee door sensors (aqara), and i would like to know if one goes offline for some reason.

Am i correct that a zigbee device reports every 60 minutes?

Will it work if I add a device flow that triggers when a device did not report for something like 121 minutes? (then it can miss one report)

u can try the devices option in ur flow section, 2nd from top. Device has not reported in …

But they only report changes, so you will have to open all windows to check this

Indeed. Does someone know if things like vibration sensors report every X hours to that they are still there/alive?

Ik know, it’s an old post.
Maybe someone can help me to solve this.
I tried to make a flow with your idea.
If: One device did not report for x time
And: Sensor is off in kitchen
Then: Telegram me, kitchen sensor did not report.

I started with the lowest option in time and tried all the options till 24 hours.
This morning I got 8 the same messages about four different sensors at the same time.
Since I set these flows I got already 13 different messages.
How? Is my flow completely wrong? Or is there something wrong with Athom?

We won’t know untill u show us the flow aye?

https: Sorry, too much private info :wink:

Try this:

Tag comes from the first card. If u don’t know how to use tags then look here.

1 Like

This flow didn’t work and I got an error when tested


The last reporting time was about 40 minutes ago.

Then u have an error in the device name while testing?

I copied the name, to be sure not making a mistake.
Also checked for space error.

Well, it’s working here so maybe double check?

I tried both options, Zone and Name
Zone I named keuken
And Name I named ASW/D keuken
Both are not working.
Heb ik weer :rofl:

And ur device is actually named “ASW/D keuken” ?

For sure :blush:

Try testing with a name that doesn’t contain a / character.

Just tested with a name that does contain the slash and that also works here.

Side note: running Homey version 3.2.1

1 Like

Tried several things but same result.
Running Homey version 4.0.0
Could that be the reason?

Dunno, that’s why I added it. First I would rename the device to something easy named. Without capitals and slashes. Maybe someone on 4.x.x can try this for u?

I tried an other one with only “voordeur” and same result.
Someone else tried already?