Homey Community Forum

Not able to upgrade to v2.0


I really would like to upgrade my Homey to v2.0 but it doesn’t work at all.
I have an Android phone (Huawei p10 pro, Android v9) with the new app installed. Starting the app and selecting my Homey works fine, but then it just shows a blue screen with a loading indicator forever…
So, no question if I want to upgrade will pop up.

Tried restarting Homey, both soft and hard. Tried uninstall/reinstall of the app in my phone. Logging out, logging in. Nothing works?!

I really don’t want to reset the Homey and start all over again.

Anyone that experienced the same problem? Any suggestions?

I don’t think resetting your Homey will solve this.

Do you have another phone you can try the app on?

No, not really… I have a pad that I could try. But, if I succeed upgrading using that and the phone app won’t work, then I’m in trouble anyway.
I’ll could test if the result is different and skip update.

Got a firewall in your network blocking the download?
Are you on the same wifi-network?

I experience similar problems with other apps since i upgraded to Android 9. With my app for Alecto Wifi camera’s the same happens. As soon as there has to be interaction on initial adding of a device it stops and shows an empty screen. On my old phone with Android 8 it works instantly. Only once the camera is added on the old phone i can correctly connect to it on my new one.

As I wrote my phone has Android 9 but when I first tried the new Homey app it was Android 8… Just recently upgraded the phone. The result is the same so I think the problem is something else.

No firewall. Is on the same network. The old Homey apps works fine on my phone.

Now I have tested to log in using an Android pad with the same result.
So I suppose the problem is the Homey itself. :frowning: