Unable to connect old Homey to android app

I bought a Homey back in 2018 and had a play, it then sat on a shelf till my new house is ready. I have now come to it and tried to connect, but failed. It is a HOMEY-EU-01. I have tried to setup with my phone but get nowhere. Each time I follow the instructions I get the response 'Could not connect to Homey. Please try again. I am wondering if there is a version mismatch as the homey is so old and the app is up to date?

I have reset the homey and have the yellow rings illuminated, I can see HomeySetup-xxxxxx on the phone but no internet, but it seems impossible to make the necessary connections.
Any ideas?

When you connect your phone to your homey your not on the internet.
After Homey is ready you automatically get back to your wifi (assuming you normally connected automatically to your own wifi)
So, don’t go manually back to your wifi after connecting to your Homey.
Then it should work.

I don’t seem to get any connection at all. This is the sequence I go through:

  1. Switch on homey. Immediate yellow light.
  2. Open app on Android
  3. Press add new Homey
  4. Press Setup homey
  5. Banner says ‘Connect to HomeySetup’
  6. Press open wifi settings
  7. Settings searching for networks
  8. Finds homeysetup-3A70A5
  9. App says ‘trying to connect to HomeySetup ….’
  10. After 3 min changes to ‘cannot connect to Homey, please try again
  11. Press retry again wifi settings page comes up and shows still connected to HomeySetup
  12. Back to app for 3 minutes as it tries to connect but fails.
    IP address 2.4GHz Android 11 App v 6.1.0 no permissions granted
    Do you think there may be a version clash?

Try doing it with a browser like Google chrome (on a device with WiFi), and going to setup.athom.com and follow the steps (except for the one that points you to the app).
As you have an old Homey firmware, it probably won’t work with the “new” app yet.

I had just started down that road, and bingo! it worked. Thank you I now need to get the firmware updated I think