How to install an original 2016 Homey?

Hi all,

I have an original Homey from 2016 that never has been installed.
Is there anyway to install and upgrade it?

Kind Regards,


Maybe this helps you to get it working:

Tried that, but after the language selection the next screen says “download the app”

No way to get around that so it seems…

Do you get other options when pressing the ALT key in the setup process in the browser?
You might get an option “Download full update” which should update the software to the latest stable version. See the description below, just try pressing the ALT key in the last steps you can take.
I read a topic that it also works when the setup connects Homey to your wifi.

“If you can put your Homey in setup mode you can solve this problem yourself. Keep Homey upside down for 1 minute. If Homey is in setup mode you then have to go to with a laptop or desktop. Select the desired language, and go to the next step. Select ‘Continue in the browser’, and follow the steps on your screen. If you see ‘search for updates’, press the ALT key on your keyboard. Press ‘Download full update’. Then choose to keep your data. Homey now needs some time to install the update. This should solve your problem.”

1 Like

When I try this It askes me to connect to HomeySetup wifi, this works, but the button next is still greyed out, so no option to proceed.

When I go back I’m back in the language selection. Then go to “continue in browser” again and then it stays on “Setup is loading” forever

Should be done connected to internet
After that it should ask

connect to HomeySetup

Then connect to the Homey Setup. Check if the notebook gets a ip address from Homey and keep it connected to Homey

1 Like

Thank you, I have checked, but the laptop is not receiving an ip-address… now what?

Is it still connected to the HomeySetup wifi?
Disconnect short and reconnect. Check that the phone is not connected at the same time.

I have to check how it works now not sure what way it detects the Homey on that network.

Yes, it was still connected to the HomeySetup wifi, I’ve tried the disconnect/reconnect thing several times, but no luck…

It’s only my laptop that tries to connect to the HomeySetup wifi

I have the same problem. An original homey with old firmware that is not used since 2019. When connected to the ip of the homey the message that it could not connect to “”, which is correct, there is no longer a dns entry for that. It stuck in a green ring.

So i also want to reset the homey, but also after connecting to the homey-wifi-network, the next steps don’t work. Is it possible that with the old firmware, the reset or install-new procedure does not work?

Thanks to Athom support I tried it with Firefox and it installed!

Very happy now :slight_smile:

1 Like

HI @rvegting what was the solution, was it only to use Firefox or also some other steps?

just use Firefox and it works!

1 Like