No response after choose homeysetup-xxxx wifi

Hello, after choosing the setup Wi-Fi connection of homey, in the Android app it says: not possible to connect to homey, try again… also in browsersetup it’s not possible to press the next button.
What can I do?

try the new Homey app on your smartphone

I think i have the newest version, its the version which is shown on the setup webpage.

You see the setup WiFi SSID in your network and connected your phone to that?

Try disabling automatic internet connection through 4G / other WiFi. When Android connects to a WiFi network without internet connection like Homey during setup, it will disconnect in favor of a internet connection…

I really don’t know what the problem was. I saw the homeysetupwifi and it also looked like I was connected, but it doesn’t work. The homey light was yellow and spinning for hours.
I tried to connect over and over again.
Finally it worked, I think PascalB was right. Everytime I changed something in the networksettings and I also createed a new, very simple ssid. At the end I used my laptop and after some attempts it worked.
But because I tried so many times I don’t exactly know what the solution was.
Thx for your help!