Not able to add Qubino Mini Dimmer to Homey Bridge

I have installed several Qubino Mini Dimmers with momentary switches. I have tried to add the dimmers to Homey bridge without any luck.
I have put the Homey bridge right next to the dimmer and toggle the button 3 times but it seems like the Homey bridge does not receive a signal from the dimmer so it is not added.
Adding Fibaro dimmers have worked without any problems.

Any suggestions/tricks to add the Qubino dimmer?

At the bottom of an app page, you’ll find support info (if supplied by the developer).

In this case it is:

I have the same problem. It seems the mini dimmer app expects to always go through first the exclusion step and then the inclusion step, but gets confused which is which. If I do manual exclusion on the dimmer, nothing happens. If I do autoinclusion, i.e. cut the power and then turn it on, it green check boxes the exclusion step and gets stuck on the inclusion step.

Sorry for the late reply. I managed to include the dimmers but had to try multiple times. Seems like it is important to wait for a few seconds after the exclusion step before trying to include the dimmer