New ZOOZ App and ZEN17 Universal relay


I was excited when I found that Home now had added an app for ZOOZ devices.

As I have had two ZEN17 for months without being able to add them to my Homey environment I rushed to power them up and paired.

Both ZEN17 were brand new and newer opened. The hardware is ver. 1.0 and firmware is version 1.04.

Both first and second step of the pairing were acknowledged and I proceeded to entering the 5 digit Z-wave DSK PIN. 5-10 seconds after submitting the PIN an error message popped up: “Something went wrong when communicating with the device. Please try again.”

Of course I tried again, several times - and with different distances from the Homey Pro hub to the ZEN17… And I unpacked the second relay too and tried with that, but to no avail. The process stopped at the same step for both devices.

How can I proceed and do some troubleshooting here? Please note that I’m a Homey Pro newbie so I need detailed description of what to do…

Thanks a lot if someone can help me get these ZOOZ devices up and running under Homey…

regards Tor

Welcome Tor,

When it’s a battery operated device, make sure to pres the pair pin each 2 seconds or so, to prevent it from ‘sleeping’. Also make sure to hold it just a few centimeters from Homey during the pairing process.
Otherwise, contact the developer here by creating an ‘issue’:

You can find support links like this, at the store app page (Issues: Report an issue)

Hi Tor,
instead of the original PIN, try to use 5 times zero = 00000.
This means that the device will be included unsecure, but this has the advantage that it has to send less data.

Even if this works, you should contact support.


What you can also try out: Restart Homey, wait about 15-30 minutes and then add the device.

It worked when using five zeros as DSK ID!!

However I understand that now the device’s communication is not encrypted?

Also I see that the two dry contact inputs are not listed in the Homey Zooz app. I badly need these too in conjunction with the two relay switches…

Anyone else having succeeded in adding a ZEN17 in secure mode with all expected properties published in the Homey ZooZ app…?

Yes, but does it really matter?
In order to access the Z-Wave devices externally, special hardware is required and the person must be within range of the Z-Wave signal.
However, Homey, and therefore the entire system, can be accessed from China, if someone wants to.

Can you please post a screenshot of the capabilities of the ZEN17, which are listed in Developer Tolls → Devices?

Here is the capabilities of the main unit (which switches BOTH relays ON/OFF).

Relay 1 and 2 have separate capabilities so we can operate each of them separately.

However there is no trace of input properties. In the manual you see there are both dual inputs and timers…

best regards Tor

Can you post a screenshot of the capabilities of one of the two relays please.

You see the relay capability in the above black screenshot. Here is the capability for Relay 2 (exactly the same):

But you wrote:

And the capabilities von Relay 1 are not visible in the screenshot.

However, if I understand you correctly, at the moment it’s only possible to switch the entire Universal Relay on or off, which also switches relays 1 and 2, correct?

Theoretically, it should be possible to “clone” the Universal Relay including the 2 relays with the Device Capabilities app. For that you have to create a so called Advanced Virtual Device with this app.

Device Class: Other (Default)

Create button
Name: Universal Relay (e.g.)
Create a real field and flow cards: :ballot_box_with_check:
Show as: On/Off
Symbol: whatever
Reflect: Devices (choose the UR)
Property: On/Off of the UR
React (set properties): :ballot_box_with_check:

Create button
Name: Relay 1 (e.g.)
Create a real field and flow cards: :ballot_box_with_check:
Show as: On/Off
Symbol: whatever
Reflect: Devices (choose the UR)
Property: On/Off of Relay 1
React (set properties): :ballot_box_with_check:

Create button
Name: Relay 2 (e.g.)

Hope I made no mistakes.
If you have questions about creating this AVD, you can ask in this topic:

Even if it works with an AVD you should contact the app developer as already suggested by @Peter_Kawa.

1 Like

Sorry I must have expressed myself unclearly. English is definitely not my mother’s tongue.

First I had problems with pairing/registering the ZEN17 but that went fine after I tried 00000 as DSK ID. The device registered its three properties/capabilities ZEN17, RELAY 1 and RELAY 2 as expected. But its two dry contact INPUTS never appeared, and I have tried to request how to find or make these two appear since then. I didn’t understand why you needed to see the relay capabilities but I posted screenshot and kept commenting that there were no input ‘properties’ to see.

Despite that the ZEN17 device in the ZOOZ App only expose these three ‘output’ ‘properties’ and not the two ‘input’ properties would it be a chance that the (or any) developer may add the ‘missing’ inputs in the app later or is it a hardware restriction prohibiting this…?

… and I have contacted the developer via github…

Yeah, looking at the flowcards for the ZEN17, there’s nothing available for the inputs…

BTW the same problem was issued 2 months ago already as I just found

The dev Leendert responded with:

Mine neither

I tried this with the Capabilities app. If the dry contacts had only been available as “Capabilities”, i.e. not in the device tile, not as a flow card and not as a tag, then it would have been possible to implement this with the app.

The app developer should be able to add the two inputs, because it’s a Z-Wave device and the code is standardized.

That is not relevant. The App Store does not always list all the Flow cards that are available in Homey.