New Homey Pro 2023 goes offline with lan cable

hello, with my old homey pro I had issue that in random time goes offline with tp link router deco x60 mesh. (2,4 and 5ghz). I tryied another routers also. same issue was with second tplink router but with third tplink router was any connection problems. when I made acces point with my phone there was no offline problem during 1 month. so I bought new version 2023 and I use LAN cable direct to my router tp link. and unfortunately homey goes also offline in some days. all another wifi devices 13x tuya thermostats, 100x shelly and more… have any problems with connections. only homey cannot connect to my LAN. I dont understand this. main computer for whole house and have so basic problem like stay online in LAN. please help

That’s weird, there isn’t any (publicly) known incompatibility of Wifi module on Homey 2019 - I suspect your access point was not the problem.

Implement some monitoring, to see the patterns, eg. check Homey uptime in trends via Sysinternals app vs Internet connectivity check app - maybe you will find something, some corelation etc.

Also ensure you are on latest firmware for both your AP and Homey.

Additional, are you sure Pro 2023 is

  • not on wifi only?
    The ethernet must be connected in one specific way:

  • not on LAN ánd wifi?
    With f.i. Android’s Fing app, or non-commercial Ning app, you can view what’s online in your LAN.

Are you sure Homey goes actually offline, or do you refer to the app message "Homey is offline, reconnect… "
You can install NetScan app, to let Homey ping your router, so you can log when H is really offline


I have the same problem with my Homey Pro 2023. Every roughly week till 2 weeks, my Homey Pro 2023 only connected via LAN cable - and the Homey original LAN USB-C is correctly connected to power supply and then to Homey Pro - w/o WiFi activated goes offline. It is connected to an Asus RT-AC68U, as is a Raspberry Pi4B and a Netatmo weather station. All devices run most recent firmware. When the Homey Pro 2023 goes offline the light turns red. All other devices connected to this router remain online so that the problem appears to be isolated to something with the Homey Pro 2023.
I have yesterday also activated WiFi in the hope the Homey Pro stays online.

Frank, latest firmware? Anyway, then it turns RED, the main docker container of Homey crashed/exited - while the Homey is offline, it shall still respond to ping - can you test ? It shall however self-reboot - does it happen ?

If so (respond to ping), it’s highly container crashed issue and Athom is getting logs automatically in such cases.

Latest firmware: Automatic updates is / was On. I have manually checked yesterday on updates and then 1.0.0-rc.118 was available after disconnecting power / wait 30 seconds / connecting power. I have installed that version then.

I have noted down IPs of Ethernet and of WiFi to test whether they are pingable when breathing red light comes on again. In case that happens, then that ought to be within 2 weeks period. I will share here.

There is only 1 change now vs last red light yesterday, and that is that I have added WiFi connection (2.4GHz) in hope that it would help my Homey to work longer w/o issues.

I do not know how long time it takes after red light comes up till self-reboot, but yesterday nothing happened for I would say 5 minutes after which I disconnected the Homey Pro adapter (and thus also the LAN adapter) from power. So no self-reboot in that time.

hello i bought next tp link deco xe75 but same result homey goes randomly offline with wifi connection and also with correct ethernet cable connection. so i bought next wifi mercusys halo h90. unfortunately homey goes also offline on wifi connection and same with lan cable. homey colour is always normal (colorised rotating ring). all another wifi devices run without problem so i think homey need some update for this bug. maybe is this connection failure in some homey log file with error description?

i am very sad from this product. it should control whole my house. homey need 100% connection.

If homey goes offline i need turn off on usb cable to have connection. reboot wifi router have no effect. after reboot homey is still offline.

I know this may sound silly but sometimes it gets overlooked as I had a problem like this - what I found that the ip address was the same as another device so they where sharing the same LAN ip not really sure how that happened - so I assigned the ip in the router for that device - then made sure everything that used the internet was turned on then rebooted the router - that sorted my problem and it never happened again -

This morning got same problem on Homey Pro 2023 with LAN cable. It rougly runs for a week and then goes offline. First time I had red light, but this morning didnt have. After removing power cable and start it up again it runs well again. Running on latest firmware 10.0.0-rc.118
I created a diagnostics report 1F19C769

This smells like a memory leaking issue somewhere

Have you filled report and sent to Athom?

You may want to check System in Insights, in case you have enabled Power user in Experiments
Also install Sysinternals app for additional info

1 Like

I have same problem, but it’s not a week.
But my homey goes offline within a couple of hours.
The led ring has normal running colors, even when homey is not accesable from app/computer.

You can setup wifi together with lan and when your lan will get disconnected, it will at least allow you to investigate…simply run setup again without resetting HP23 or restoring data. Then,when you will find the possible cause (or none and you would suspect LAN adapter faulty),for sure contact Athom.

Same probleme here. Connected my homey pro (early 2023) with the Pro-Ethernet-Adapter to my LAN Switch . Sometimes it works only for a few hours, sometimes a few days. When the homey is offline, i cant ping the ip adress. The ring is normal, not red. Updated today to version 10.0.8.

Did you try an other set of USB-C cables? Sounds odd, I know, but there seems to be a batch of crappy unreliable cables delivered


have the same issues with a missing LAN Connection, too.

It worked very well for several month, but with Relase 10.0.9-rc.1 my Homey lost his connection via LAN.
Only WIFI is still working.

But the system is unstable now. Within 6 days now 3 crashes with lost communication.
A manual new start solves this problem for a while

Hi Martin,

rc.1 = beta version, can contain bugs or f…k up your Homey. Probably not, but there’s no guarantees. You’re a beta test-volunteer now :wink:

I think you’d share your findings with Athom developing, not here while the issue is the firmware update for almost sure?
If I were you I would revert to v10.0.8, especially while your H. seems to run fine on that version.
Here you can disable the Experimental updates:

Yes I know, but this version helps to reduce my zwave problems a bit.

It reduced my required homey restarts from 1x per hour to 1x every six hours atm.

1 Like

I’m on this version since day 1, having Homey connected via LAN only and having 0 problem with connectivity … do I get your right, you run LAN and Wifi in parallel ?


LAN is connected, LEDs at adapter are blinking, but homey is only connected via WIFI to my grid.

The LAN Adapter works fine with other devices and has worked with my Homey since Feb, The dual setup LAN/Wifi has worked without any problems

After some days LAN-connection comes back this every after a reboot.
Will have a eye on this case