New Flows not showing in Google Home

I’m new to homey and just started using it. So far everything seems to work great and I can control all the divices I want.

I use the Google assistent for speech. First I made three flows in Homey. I made a few “routines” in Google home app with a voice command as starter and a Homey Flow (that appears as “scene” in the Home app) as action. This went well.

The problem: after the above, I made a few more flows in Homey. But whatever I do, the new flows don’t appear in de Home app! The only thing I see under the scenes are the first three flows I created, and 4 generic ones (good morning, good night, at home, away) that I can’t find anywhere else in the Homey app or the Google home app.

Does someone know what is going on here?

PS. I translated the names as good as I could, but they are in Dutch.

Oh, I tried:
Rebooting the apps and my phone
Clearing cache
Renaming the flows
Putting the flows in folders
Asking Google “sync my devices”

Also, when I edit the 3 flows that Do show up in the home app, the name of the flows (scenes) changes almost immediately, so it IS syncing with Homey. It just doesn’t show anything new I create.

add them to your favorite flows in homey

… Thank you, that solved it.

1 Like

No problem

Where do you find scenes in the Google Home app? I don’t see those. I can activate a flow by saying “Hey Google Activate…whatever flow name is” as long as the flow is favourited in Homey app

When in the Home app, click on routines, make a new routine, pick something as a trigger (for example “we go to bed”), and select the scene you want to start under add action - smart home devices - scenes.

Hope this helps. Again, my account is in Dutch so I’m not sure about the labels, I translated them.

1 Like

I am having the same issues.
Even when i added the new flows to my homey’s favorites.
It does not show up in the list of flows in google’s app.

It’s weird, my first new flow, i was able to see it in the list after restarting apps.
Now that is not working anymore.

So i am havin the same problems as the OP, but i added them to the Homey’s favorites and it’s still not working.
Anyone ?


Thanks, but no, i have synced them many times now.
The devices are seen, but the flows are not.

I have the exact same issue.

Add a virtual switch, and let it trigger the flow.
The virtual switch appears in Ghome automatically, if this switch is enabled

Else, saying “Hey google, synchronise devices” does the trick.

If you named the virtual switch “GardenHouse”, you can trigger the flow by saying “Hey google, switch GardenHouse on”