New driver for [Smart Siren NEO] - [_TZE204_t1blo2bj] / [TS0601]


I was so impatient to see my siren working that I tried to implement a new driver.
I got the original driver sirentemphumidsensor designed for a similar siren but with a different manufacturer ID.

BTW It seems that the devices from NEO had now the TZE204_t1blo2bj manufacturer ID !

I modified the original driver by changing the manufacturer ID.

I was able to pair the device.
I wrote some flows and the orders were sent to the device.
Activation (onoff) seems working.

But : there are no values on the device screen (temperature, humidity and siren state)
I could not be able to get any sound from the siren …

Thank you for your help in order to fix these issues !


In order to do the test of my new driver, I implemented an app which is a clone of an existing app (Tuya Zigbee). I only changed it’s name.

As I do not obtain good result with my new driver, I tried to pair a very simple device (temperature and humidity sensor). This device worked perfectly well with Tuya Zigbee app.

But with my clone app, I can pair it but I can’t get any data … quite the same issue I got with the siren.

So, I’m wondering if my clone app wasn’t disturb by the pre existing Tuya Zigbee app ?

In my clone app, I have just changed the name. Probably, it’s not enough … What should I have further changed?

Thank you for your help

Had you implement the driver for the siren with “manufacturerName”: “_TZE204_t1blo2bj”?

I am on the way to have a running driver.

I found a few errors in the driver included with the tuya zigbee app.

But, up to now, I have nether hear the sound of the siren …

Best regards

I have also tried to re-implement this driver. We should pool resources. My version can be found here:

This is basically a copy of the Tuya app with some minor changes. In a nutshell my changes are:

  • Removed the temperator and humidity sensors
  • Updated the dataPoints mapping

I’m really perplex about this driver …

I’ve tested the siren with smart life : it is running but it is only possible to get 5 different sounds.

In order to have good info about this driver, it would great to contact J Revillard who was at the origin of this driver

I found his repository on GitHub : Add Neo Siren alarm driver by jrevillard · Pull Request #342 · JohanBendz/com.tuya.zigbee · GitHub.


I’ve contacted Jerôme Revillard.
He has seen my message …I’m hoping an answer

Concerning this new siren, I’ve noticed differences from the old one.



Thanks for the links you posted. With the help of the driver here I managed to get the siren to start working:

I can now change the volume, tune and toggle the siren on/off. Latest code in github.

Still a work in progress. Happy to merge any other changes into this driver.

Finally, what are the changes ?

The magic change is that the alarm (onoff) capability is on DP 13. I will finish up the changes to the driver tonight/tomorrow to get everything tidied up and then will see if i can create a pull request to get this merged into the community Tuya app.

Latest version in github should be fully functional. I will do some more extensive testing tomorrow.

Ok, I’m going to have a look by the end of afternoon …

It is running on my Homey …

I saw you have cancelled a major part of processResponse which contained pretty sophisticated code … Why ? and why it was here ??

What about integrate again temperature and humidity ? It could be interesting for some people …

But, the most important is that the siren sounds !!!

I could never see processResponse being called - but when you change settings (or when the siren times out) I could see the processReporting being called. Setting updates are reported there.

As far as I know this particular model does not have the temperature and humidity sensors. See:

You are right, even with smartlife I can’t see temperature nor humidity ….

Best regards

I have tidied up the code. The action cards don’t work correctly. As long as you have just one device they work fine, but once you have more than one device the action cards only ever execute on one of the devices - regardless of which device you reference from the flow. Will appreciate any help with this.

I’ll have a look …

I got some help from one of the forums. I have fixed the action cards - I believe everything is working now. Final version in github.

I made a test with the previous code and 2 sirens.
At the first attempt it was not OK for the second siren.
But after this first attempt it was OK with the two sirens …

I see you have fixed the issue ! What is the problem ??

Best regards

I have installed this new driver with CLI on my HOMEY and, now, my siren can sound !!
Thanks to Johan Rossouw who have done this new driver !!

You can find the code on GitHub : GitHub - jrossouw/page.rossouw.homey.test: Homey Pro device testing

This thread has been moved to the English forum, if you have any problems with that please feel free to contact me or another moderator.