Homey Community Forum

Nest Authentication - Device Retrieve Failure

I’ve installed the Nest App from the Apps list (Homey V2) and ran the configure option. The app connected OK to the Nest Home Service and app indicates it was successfully configured. Now when I go to add a Nest Device (Thermostat or Protect), I get asked to login again. Have removed, re-added and reconfigured several times, also rebooted Homey and done a factory reset/rebuild; still doing the same thing! Would be very grateful for any assistance. Thanks!

Same issue here.

I had this

Try on a different device… It wouldn’t work on my Note 8 in chrome but worked fine on my Huawei Tablet

Tried 4 different Android instances now, still no luck! Tried P20, OnePlus6, Nox and BlueStacks.

have you tried a browser different to chrome?

I cant remember exactly what I did…

but… one thing to try is go to the nest settings and Deauthorise

then try and install the nest device and see does it prompt it…

Thanks for that KonradWalsh! Got it to work in a round-about way!

  1. Deauthorised the App.
  2. Tried to add a new thermostat, it prompted for authorisation and then allowed me to select the device.
  3. Then tried to add the Nest Protect CO/Smoke alarms, same issue as before.
  4. Deauthorised the App again, leaving thermostat in place.
  5. Tried to add the Protect devices without authorisation, it prompted me again and let me add them both.
  6. The thermostat seems to have adopted the new authorisation as it’s still working!

As I say, a bit of a workaround, but your recommendations worked! Many Thanks.

1 Like

Hopefully it saves the next person the annoyance

1 Like