Neo Coolcam power plug range NAS-WR01ZE

Hi Homey users! I am always looking for more fun stuff to connect to homey so i bought the Neo Coolcam NAS-WR01ZE. I already have door sensors too which do work great!

But it looks like i have some range issues with the NAS-WR01ZE. When it is plugged in next to the homey it responds very well. But 3 meters away the plug ignores some commands. 6 meters away, and only a wooden cabinet beween them,
It does not receive any commands.

Is someone using this plug already at a further range? Thanks!!!


Right now I have 4 neo plugs and all of them are work well.
Sometimes neo devices are buggy.
So try to restore to factory settings ( 10 seconds button hold ) and then re-add it to homey.
One of plugs is placed in my ground and makes 4 hopes to reach homey but everything works fast.

I only have one, just to experiment with it.

I’ve red the factory reset trick on this forum, so unfortunately i did already follow that procedure.
Most of the wall sockets on the floor level do work quite well, but two of them have issues.
One level up in our house (concrete floors) work as wel.

Could these plugs be sensitive for not-grounded wall-sockets?
The two problematic wall sockets do not have ground pins. (the one upstairs is also not grounded, but do work well)

They are a bit buggy somethimes indeed.

in my experience i pair them as close as possible to homey (like 10cm) and then they work great on longer distance. i’ve got like 20 of them, and had to send 2 pieces back because they where not responding at all.

Good to hear positive experiences, gives me some hope :wink:

The first time, the pairing was done on the second floor of our house, the pairing failed at the last step (so device was not added, but did need to be removed from ‘remove z-wave device’ menu).
After that i took my laptop and sat next to the homey and paired the device (after giving the power plug the factory reset).

I’ve created a new test-scene to test the signal the other way,
when the wall socket device is turned on, Homey sends a push signal to my phone.
But the issues are exactly the same, crazy right!?

Also tested the device in our bathroom, which haves a very thick concrete floor with metal net in it,
and the homey responded to the power-on all the times…

I also just testing unplugging all christmas tree lights (i received my wallplug while my girlfrind was decorating our house :stuck_out_tongue: ), but did not preform any better too…

i think i’ll buy another one at a later time, and plug that one in a socket that did respond well,
hoping the mesh network will do the trick.

If anyone got some tips, please let me know :slight_smile:

All my plugs are not grounded, so it is not a problem.
I always add them near homey, then move to desired room. In the room I turn it on and off several times, so z-wave could find it best route. But may be your plug is really buggy so try another one :grin:

Yesterday I noticed the same range problem. Close by works perfect. 3 to 4 meters plus : only switch on but not off.
I also don’t get any poweruse information, even when it is next to Homey.

never had any real problems with the neo coolcam wallplugs, several are located a long way from homey 40m plus, relayed by 2 other 2-wave devices it can take some seconds to react

new wall plugs I register by adding a new wallplug in the app and plug them in near homey and it is added directly without any button pushing

Hi I have similar issues. 3 out of 4 malfunction badly even within 1 meter from Homey after a while they start to not react anymore. They also seem to mess up my mesh network as some other proper devices (Fibaro) route through the NEO powerplug also start to disfunction. Btw I ordered directly from Aliexpress, not sure if these are exactly the same as the ones sold locally in NL, but would not think so. Other NEO (non mesh like PIRs work perfectly). I am starting to replace the NEO power-plugs ;-(

I am not really satisfied with the Neo Coolcam wallplugs either. Every now and then the wallplugs become unresponsive. They cannot be switched on or off by the Homey-app, report erroneous status and even the small button on the wallplug itself does not work anymore. I conclude it is not a problem with the Homey then. Removing them from the socket and re-inserting after a few seconds restores the connection and everything works again. One wallplug, a floor away from the Homey, behaves like this maybe once a month or less frequent, but I have 5 wallplugs in a cupboard close to eachother for video and audio where the problem occurs at least once a week.

It almost seems that wallplugs very close to each other mess up the mesh network. Could there be a setting for the Neo Coolcam that would help? Or would it help to add some Fibaro’s in the mix?

I did add a Fibaro power plug to the network. Just days after repairing everything (ranging from re-inserting the plug in the socket to deleting and re-adding it to the Homey) I have problems with some of the Neo Coolcam power plugs again. I now have six of them (and one Fibaro) close to eachother to control AV-equipment. It almost seems that the malfunction has something to do with too many other plugs nearby. Two separate Neo Coolcam power plugs in different rooms work without problems.

Did anyone else experience similar problems?

Yep, can confirm that. Had huge problems with 2 plugs in the same extension cord. The mesh kept changing and the both had completely different (ad illogical) paths to Homey. At some point, one of them was completely unresponsive until i took it out and plugged it in again.
I put them a little more apart from each other (about 150 cm) and now it is better, but still not quite optimal. One of them has a complete different (and longer) path than the other.

I have two other places with a set of plugs within 1 meter of each other who show the same behavior. Alas i can’t change the position of them.

I think it also has to do something with how many plugs (where they can “choose” from) are in between them on the route to Homey or maybe with the placement or working of the internal antenna in the plug.

I also have similar problems. My garage was a big problem for zwave. At this moment i have two neo power plugs working fine in the garage. Strange enough the neo doorsensor in the garage behaved very buggy. I have tried everything, pairing, unpairing, remove by the app, remove heal etc developers page, resetting etc etc. I have removed the neo doorsensor and added a xiaomi aquara zigbee doorsensor. Fortunately that works great.(had philips hue bulbs in the garage already)

Thanks for the feedback, Peter.
I do not understand the technical reason why too close to eachother poses problems. Does anyone know whether this is a known problem for any Z-wave network or a bug in the Neo Coolcam wallplugs? Would Zigbee or KaKu behave better in this respect?

I think Z-Wave suffers from the fact that both switches are so close that they try to be each other’s neighbor or something like that. But i really don’t know for sure.

Kaku would definitely not behave better. This problem is known with KaKu devices because of the signal protocol. If two units are close together it often happens that the signal for the first blocks that for the second so the second won’t respond to the signal if it is in a sequence. If you wait ten seconds and then signal the second apart it will work.

Zigbee? I really wouldn’t know.

Created issues here with Neo Coolcam wallplugs Z-wave devices here myself when I unplugged the wall plug which was near Homey (range 20 cm).

Whatever i tried, deleting wallplugs, re-adding them,, pull out the wall and back in… it only worked again when put back the wall plug near homey.

So I was wondering, what is the distance between your homey and the nearest neo coolcam zwave wallplug ? As this seems it might be a solution for mesh network issues.

If you disturb the mesh, it takes some time for the devices to discover new routes. The quickest way to establish this is to do a PtP after removing the plug and have some patience (few hours should be more then sufficient) after Homey is started again.

1 Like

Works like a charm again now. Sometimes I get the red time-out bar in the Homey app when I switch a wallplug but at least there is connection again. By the way; Didn’t need to PtP.



Hi all,

Strange Z-wave plus behavior here again.

  1. The route the wall-plugs take is not logical (looking at the situations in my house). For example the device “Lichtslang” really takes a detour. Why doesn’t it connect to the nearest wallplug and routes one after another the shortest route?

  2. Looking at screenshot 1 i have many times that in the column ROUTE mentions “prev. last working route”. Sometimes it’s there, and then suddenly it’s gone.

  3. Many devices in the column “FLAGS” have UNREACHABLE. In this screenshot only 1 but sometimes i have 5 or 6 UNREACHABLE. When i “test”, “send test frame” or “heal” it sometimes get responsible/reachable. But few minutes later it is UNREACHABLE again. It works very buggie…

  4. In the 2nd screenshot you can see a NodeID in the routing route with #4 which is very strange as this isn’t an existing node number for long time (however i do reuse that device somewhere else in the house after a wall-plug reset ofcourse) . That has been reset and got a new NodeID number long time ago. I also saw a NodeID with #2 popped up a week ago? Why is that? Any idea?

@PetervdK Any idea? And how are your devices working lately? Can you post a screenshot of your developer area for Z-wave? Many questions, because many stange behaviour…

i have added screenshot 3 (this was made 1 minute ago) and gives a reliable view of the situation as it is most of the times. You can also see that NodeID number 2 is back in the routing of the device “Bank” while it isn’t a device. Very weird.

I have tried PtP many times but can’t get them to work flawless anymore.
Homey is updated to version 2.5.0

Screenshot 1

Screenshot 2

Screenshot 3