Neato no longer works

It is not possible to add a new Neato machine to homey. I have installeren the app. Try to add a new neato machine. Clicking the button in the app and the app tries to go to the Neato site. However that link can not be found! What am i doing wrong? How to fix this problem?


I reconnected the service just today after the Neato service was misbehaving badly the day before. Could it be there was a temporary problem with the Neato services, maybe try again later?

Also, I recommend installing the test version of the Neato app. The “normal” version has a bug with reconnect times which was fixed ages ago but never set live.

The app hasn’t been updated verly long and is a bit shakey. If you can’t get it to work there is a workaraound possible so you can start the robot through IFTTT (using webhooks, since the IFTTT service is about to be discontinued):.

I created a tutorial today using this as an example :smile:

Hi Michel,

just delete app and reinstall…than it works like normal again. HAd the same problem…now it works perfectly again.

I tried both 1.0.2 and 1.0.3 without any luck. Same issue as Michel.

Since it doesn’t support zone cleaning, I don’t see much use for it. Asked Neato support and their reply: “Unfortunately, This is not supported and there are no plans at the moment on this.”
Anyone else has found a good workaround for this - perhaps using Google Home, SmartThings, IFTTT, or something else instead of the Neato app?

I believe someone reverse engineered zone cleaning commands for Home Assistant. AFAIK no other platform supports it because Neato does not put any effort in making a proper API for it.

I had it working with SmartThings* sometime back, but don’t want to use SmartThings after changing to Homey. It seems to be somewhat supported with Apple (possible to add an automatization for zone cleaning), Alexa, and Google Home. I think there was an API on the developer’s site on Neato but can’t find it anymore.

Is it Neato that should be asked for a proper API or is it Homey that should build an app (since other platforms can work with Neato incl. zone cleaning)?

*[RELEASE] Neato (Connect) V1.2.6c (Botvac Connected Series) - #868 by cscheiene - Community Created SmartApps - SmartThings Community

It looks like it is working partial again.
The link to the Neato site is found again.
(… part removed in the link)


What is going wrong now?


Same for me - anyone know what’s wrong?