Neato D3 connected question


Within Athom’s last weeks newsletter there was this Neato D3 vacuum cleaner offer, bought it and had it delivered the next day. So far so good. And the thing seems to do it’s job fine as well, except for the connected part… and that is why I wanted it for, homey to rule everything. Who doesn’t want to say “Okay google, start vacuum cleaning”?

I first installed the neato app and created an account. Powered off the robot, powered it back on setting it to pairing mode and that all worked fine. The app indicated there was a new firmware, but clicking “install” kept saying: “robot needs to be docked”, while it was docked and loading. Could not get it to upgrade the firmware, but the commands worked from the neato app.

Now I installed the Homey Neato app, adding the vacuum cleaner worked fine as well and now the Google assistant integration works I’ve setup a virtual device to start the start/stop flow and could ask Google to start / stop vacuum cleaning.

This worked for some minutes. After that a red exclamation mark apeared to my homey device within the details “Neato API not reachable”. Also the Neato app could not connect anymore. I removed everything, performed all steps again, everything was working great… for some time, until the same issue came back again.

The vacuum cleaner is on and within it’s docking station. Why do both the Neato app and the homey neato app mess up communication with it? (or why does the vacuum cleaner stop responding?).

I’d like to know if this is an device issue, if so I could still return it within the 14 days returning period, but hope to get this resolved.

My Neato D5 only works with the Neato app. Communiction with Homey does not work. I don’t mind because I use the scchedule in rhe Neato app.

Hmmm…, that’s not a good sign for me :smile: Would be strange if Athom sells the device on discount without having it working. I’ll mail Athom support about this, hopefully they can help sort it out. I want to be able to talk to my vacuum cleaner :wink: and I want Homey to signal me if the cleaner gets stuck or is done. Homey should be my replacement for all of these other kind of apps. And Homey also knows when I’m away, so could trigger the cleaning. The Neato app has none of that.

This is the only wise thing you can do,
b.t.w. you have seen that A beta version of this app is available.

iam for sure i dont want to do that :slightly_smiling_face: i want automate things, that means it cleaning the house when not at home.

Already reported some monts ago, that it wont work correctly with homey, also that after connecting the neato to homey, thats often not connecting to the Original neato app anymore.

Would be nice if they get it working some day, but its no big deal for me…setting a schedule in the app and walla. all good

1 Like

Sure, I want it to be automated as well using homey, detect that nobody is in the room and go, stop when someone comes in :smile: But I also want it to start if I tell it to.

Would be weird if they don’t have it working correctly, why would you ever promote it if the implementation is buggy or half working?

Wel thats a very good point of you, but sadly athom thinks different in some points.

Back on-topic, i maked a schedule so thats cleaning when at work, and the few times that iam at home that time is no big deal.

Why would the implementation be buggy when

Sure it’s not an internet thingie?

Hi Cuflee!

I agree, it would be great to be able to read out whether the cleaner gets stuck or it’s dust container is full and react to it in a flow.
Am I right that reading out these state messages are not yet implemented?


Hi Manfred,

The card can act on the following status changes:

  • Vacuum cleaning
  • Spot cleaning
  • On docking station
  • Charging
  • Stopped

I’m not sure If “stopped” is also “stuck”. It can also raise events on battery level changes. You can also give it the following commands:

  • Start cleaning
  • Start spot cleaning
  • Stop
  • Back to docking station

So I guess that if you automate it to “Start cleaning” and after let’s say an hour issue “Back to docking station” if there is a “stopped” event in between something is wrong and it’s probably stuck.

This all seems great, but I can’t get it to work. After connecting the connection seems to work for a small amount of time, but just as you get enthusiastic about it there is a red exclamation mark and the entire connection is out and you have to remove and repair everything again.

Hi Rocodamelshe,

The device is on, its about 3 feets away from the accesspoint. My phone with the Neato app and the Neato homey app running on it is in the same room having full WiFI bars.

Initial connection works fine (so no (inter)net connection there), but breaks after some minutes over and over again. I therefore doubt that it is an internet thingie.

Is there anyone out here that has this device working properly with Homey?

I have the D3 for almost a year and never had any problems working with Homey. It makes its round trough the house every night. It’s true that the neato app has some options that are not supported by the homey app.

You can make a logic variable to count the number of times the robot is on its way and send a notification as reminder to empty the dirt bin as soon as the variable reaches a specific number

Thanks Simon, good to know that it can be working. I somehow got it to update to the latest firmware last night, did nothing other than what I did before, it told me to place it upon the docking station twice but after that it just updated successfully, but about an hour later again that exclamation mark within Homey and the Neato app unable to connect. It’s almost as if the robot does a factory reset or something.


Athom support was quickly with it’s response, Kars asked me to update the firmware, that failed a lot but all of the sudden after some attempts it decided to up perform the upgrade, but that did not fix the issue so Kars forwarded me to Neato support (

Again within a day there is Mario, indicating the below things to check. I answered with the parts in Italic. Biggest issue is that the wife is happy with the thing as-is and she does not care about home automation at all, so could be that we just leave it as a dumb device.

• Make sure your wireless router is 2.4GHz.
It’s dualband, there are several Ubiquiti Unify UAC-AC-LR accesspoint throughout the house creating a large 2.4 / 5 ghz WiFI network.
• If you have firewall settings setup on your router, we would recommend changing them to low settings in order to improve the robots connection to the Neato server.
They can connect with the app for some time, so I don’t think this could be the issue?
• Set the broadcast channel of your 2.4 GHz network to either 1, 6 or 11 as keeping this setting on automatic can cause random disconnections.
I have no idea how to change this yet and do believe every accesspoint should have a different channel, but if this is the case, should it not also start working in some occasions again? Right now, if the connection is gone it’s gone. Like the robot completely forgot about the WiFI.
• If the disconnection happen systematically, you might need to extend lease time on your router. We would recommend contacting ISP and extending the lease time on the router.
WAN IP address is near static, I don’t think this ever changed.

I have read that multiple people have this issue.
And the problems starts when both homey and the app want to connect through the same wifi network to the neato.
Is there a reason you still need the app once the neato is connected to homey?
Does the connection work if you disable wifi on your phone for a while? If you don’t need the app any longer perhaps remove it and just do everything through homey.

I am still considering buying one as well and still have a few days.

Hi Damon,

Hmmm…, I didn’t even think about checking that. I’ll repair everything tonight again and will remove the Neato app afterwards. I do doubt that it will work cause I do know that I did try without the Neato app “open” already. Unless it has some kind of continuously active service on my phone I don’t know if it will work, but will try and let you know. Tnx for the tip.

Found the source again, couldn’t remember where it was.
Check the reviews on
2 reviewers saying the same, although both mentioned the android app of neato.
And yes please keep me posted since it might help me decide to get one or not :slight_smile:

Just received another update from Neato support. My WiFI is dualband, the robot works sometime, so don’t think that that is the issue. I have 3 UniFI accesspoint to cover WiFI throughout the entire house, can stream a video uninterrupted from downstairs toilet to jumping on the roof. While testing the robot is next to the AP. Don’t think I’m getting any further with their supportdesk.

*Connection issues are most likely about router settings being incorrect and Wi-Fi signal strength being weak or lost in some places in your home. *

Your robot model D3 Connected can perform only on 2.4Ghz network. So setting your router to that frequency would be recommended.

As for the rest of the troubleshooting steps I suggested, if you are unsure on how to set it up, please contact your internet service provider. They should guide you trough setting up the channels on your router. However, take note about previous router settings before changing them in case they are needed again.

Let me know if the issue still persists, I will then know more about it and see what we can do to resolve it.

And u did try to connect it to a 2.4 network? Like a seperate 2.4 network, not dualband?

It’s a dualband, so guess that’s like having both a 2.4Ghz and 5Ghz right? It should connect to the 2.4Ghz and probably also does find it’s way to do so as it has been working. Just like it should not switch to our neighbour’s WiFI I’d also expect it to stick with the 2.4Ghz wifi then. They don’t say their can only be a 2.4Ghz network, that would also be a bit weird restriction.

I’m not going to buy a complete new 2.4 Ghz WiFI only network of accesspoints throughout the house just for this. I’ll see if I can find some old 2.4Ghz only AP to borrow and check with that as well.