Nanoleaf Crashing add Devices


I recently purchased Nanoleaf Elements and have been trying to add it to Homey. I

t doesn’t let me add my devices and just keep crashing at the stage where i should press them power button for 6 seconds, it finds my device but instantly crash with an error massage saying [object object].

I have reinstalled the application, I have set Nanoleaf to factory settings… but it still fails.

What can be?

Don’t know. But have you tried the test version v3.0.1?


I had the same issue (Nanoleaf Elements), installed the test version and now I can add the device. But some of the colors are not working when I try to change in the Homey app. A few of them return an error about connection problem.
Brightness, on/off and a few colors work.

I have major problems with the panels in general, can’t connect to them using the Android app, but managed after a few tries using the Windows app, they seem very buggy in general.

I have tried multiple phones, accounts, resetting them and reinstalling the app. Always the same issue, gives an error about wrong pairing code.

Using separate 2,4 GHz network for my IoT devices, can see it gets an IP address in the router control panel.

Don’t use Nanoleaf devices myself, but for me it sounds like an Nanoleaf app bug. So I recommend contacting Nanoleaf support.

Yeah, I think the main problem is the device itself. But since the Homey app (the non test version) also is buggy I wanted to mention it here as well.

I have already sent Nanoleaf a support ticket, but they are not so fast when it comes to giving me a reply…

From the Windows app I managed to update the firmware, but that didn’t help much solving the Android nor Homey issues.