Namron thermostat 4512759


Trying to add the Namron 4512759 thermostat to Homey bridge. Pairing seems successful but when clicking the icon in the Homey app I get the error “could not get device by id”. Same with web app. Have tried another thermostat, same results.
Also tried factory reset, pairing with double click as it’s mentioned in the manual, tried the normal 5s when pairing, re-installed the Namron app in Homey but no go. Firmware 84 on bridge.

Anyone experienced the same issue or has successfully paired this thermostat with Bridge?


Diagnostic code below


First of all, welcome to the Homey Community!

To make sure you are aware of the forum rules, please read the Welcome to the forum! post here.

This is a community forum and your posts, questions and suggestions will not be read by Namron AS. So please contact Namron via the contact options in the Homey App Store in the lower, gray field.


Just saw this topic and the test version of the Namron app solved the problem. So please try this app version and check it: