Mqtt broker stopped working


Is someone else also experiencing that mqtt broker is not working anymore or not correctly?

All tasmota sonoff devices where suddenly unavailable
since a few days and don’t get them back to work.
Tried to install new broker, deleted all devices but when re-adding them they don’t get connection with broker.

Already installed test version 3 as well to see if that would fix the issue, but without succes.

Services are trying to authenticate to broker, as I can see from logs on both sides, but they don’t connect somehow.
Gave them new user password combi to check, but without effect.

Who can send me in the right direction?

Have you tried disabling authentication altogether? I assume that the IP address that you’re using is correct.

Hi Robert,

Thnx for your response.

  • IP is as far as I understand correct, hasn’t been changed. I use ip of homey for this

  • authentication, are you suggesting I need to remove all authentication, so also on devices in the mqtt settings for this? I had per device a user configured.

I was wondering if a user per device was nessecary? But for now I first want to get it working again. Before optimizing the user management.


When I try to add in Sonoff app generic (tasmota) device, fill in config.I can’t get connection to mqtt broker it says.

It worked yesterday once to get to next step and soft reboot device, which it recognized, but short after device was unavailable again.

I also noticed these messages in homey:

It could be that the test version uses a different config setup causing the “not valid” messages. Sounds like you may need to uninstall the app and start over.

Ok will try that again.
When uninstalling the broker app, will it also remove all existing config data?
In other words, will config data be reset as well when removing app?


I assume so, yes.

Unfortunately that didn’t do the trick.
Also tried to connect with mqtt explorer, but also get a connection refused message from this.

Is there any way to test if broker is working correctly?

It is showing weird behavior…

It showed at random moment status: unknown
Stopping and restarting again made it work again.

But this doesn’t made me more confident about working broker.
So any tools/ideas I can use to test broker?


Use any MQTT client to see if you can connect to it.

Thnx, but I can’t connect with any client on the broker…

Weird situation. As long as nobody else is experiencing this it would be probably only mine setup.

Don’t hope to do a complete reset of my homey to fix it.
Keep you posted if I’ve solved it.
Thnx for ur advice so far.

An acquaintance of mine asked yesterday if I remembered how to add a plug with Tasmota. All of his 12 devices were no longer working.
Adding them didn’t work either.
After reinstalling the mqtt broker software everything worked again.
He did have to search for the devices but all devices were found again.
Without adding again.

And was he using Sonoff app in combination with that?
Do you remember what kind of plug he was using?

He used the Sonoff AP and a couple of Sonoff mini’s.
All with Tasmota firmware.

I’m dealing with the same problem. @PjO did you managed to get it work?

FWIF, these are te errors i get with the client and the broker.

No still no solution.
Can not connect to broker.
Have similar error messages.

It seems like the MQTT Broker is running on Homey, since i can connect to it via MQTT Explorer and see all the topics. However the client within Homey app cannot connect to it. The device i try to control via Homey say ‘Connection with MQTT briker failed’.

perhaps @robertklep has an idea to solve this? He has helped many others before with MQTT issues.

Have you tried using as IP address for the client to connect to?

Thank you for your prompt reply. I tried unfortunately without success.
Weird thing is that it does say that its connected in the client log information.

@PjO there is a work around since you are working with Tasmota. There is another app called Tasmota MQTT, that allows you to add the tamsota devices. This seems to work for me.