Sonoff tasmota connection problem

Hello everybody,
I recently got a sonoff basic with tasmota firmware.
The idea is to use it to open a fence using the tasmota inching function.
I connected it to my house network. We have a main router with its wifi ad a mesh wifi network based on Google wifi repeater. Homey is connected to the Google network (
When trying to use the sonoff app to connect via mqtt, I always receive the message that connection was unsuccessful and if a take a look to the sonoff mqtt console it reports that it can’t connect to server.
I also tried to connect it to the primary wifi, the one coming from the router, but the problem remain the same.
I attach pics for both the error message and the configuration that’s actually on.

Anybody has an Idea of what I’m missing, what shall I change, what I’m doing wrong?

Thanks everyone for the support.



Both the Sonoff device and the MQTT host have the same IP-address (, which doesn’t look right to me.

Hello Robert,

There’s probably something I’m missing in configuration due to my ignorance of the matter.
I’ll better read something on the argument before going on.
I could anyway set inching time to 2 secs as I want ed and it works. It’s a good starting…

Thank you

Hello Robert,

I got it working.
The problem was due to my ignorance about MQTT. I had to configure the Homey broker app, your app and the sonoff in the correct way. Not the foolish way I did.
I’m ready to install it now to drive the fence.

Thank you again for your excellent work.


1 Like

hi, i’ve found this post and i think Robert can help me , i’ve a similar problem,i cant connect the swith with homey but i think in an app problem, the tasmota is configurated with homey host( its right?) and in the sonoff app the ipp mqtt broker is because mqtt broker is inside the hub ( right?) but the app stay at first step , thanks

in the mqtt broker log i’ve see right now this :
20191204-15:53:30 luce has subscribed to topic cmnd/tasmota/#
20191204-15:53:30 luce has subscribed to topic cmnd/Luce_fb/#
and more similar log, ithin the swith configuration is right but i dont know why the app not dialog and dont found the switch, thanks again

I had many problems to configure mqtt but finally I got it working. Mqtt is a standard client/server architecture but the server is called broker (it was confusing for me) and you have to install the mqtt broker server on homey. I attach the screenshot of how I configured it. If you’re Italian you can get good infos on indomus web page and make a search, they have a good tutorial on how to setup mqtt.
I can’t send you the screenshot of the tasmota setting as it’s no longer connected. I replaced it with a shelley. I suggest to do the same, it’s much easier and faster and you can set it to do the same things as sonoff but in a flawless way. When it will burn, soon or later, you can replace it faster and easier. It’s also cheaper.
Have a nice night/day.

1 Like

Thank you Nicola, my problem was solved installing homey app in another phone, setting are right but my old Meizu wont collaborate, after using another smartphone everithing was fine, the tasmota work very well, i appreciated you advise, i Will try with a Shelly i need to buy 30 switch cheap to domotize 3 appartments , thanks again F.P.