[Modding][HowTo] Guide to Jailbreak a Homey Pro 2023

Could be many things.

  • wrong SSH port.
  • SSH failed to install.
  • Files have the wrong chmod (especially if you use windows)
  • SSH is still installing
  • Added the files only to one root directory.

It is difficult to tell from afar.

Don’t know why, but i first activated SSH Sandbox, wait till i can login into the sandbox. Disabled it, wait a few minutes.

Then copying the files again, just to be sure ssh-setup would run again. Booted, and it works!

At the first try, i saw that the ssh-setup did his job, home folder etc was created, port was changed in the config, don’t know why it was not working…

Thanks anyway!

Hello. I have software 10.0.9-rc.1 and I’m trying to jailbreak, but I can’t seem to do it. I’ve tried many times. I’m using a Windows PC and have followed the guide here. Any tips?

Elaborate on what “can’t seem to do it” actually means. We have no idea how far in the process you get, and where it stops working for you…

3 Likes

Still works fine here (FYI)

1 Like

I’ve tried with Windows and transferred the files to ROOTA and ROOTB, and unlocked the disks. I’ve also tried today with Linux, but the same issue persists.I also give the files ROOT access. When I try to connect with Putty, I get a “connection refused” message.

I assume you copied both files to their correct location?

ROOTA/etc/rc.local
ROOTA/home/ssh-setup.sh

(and same for ROOTB)

Did you also configure Putty to use port 2222 and not port 22?

Yes, And i do not need to activate sanbox shh in homey?. I haven`t activated it.

a windows machine hmmmm, did you add port 2222 to the firewall?

Nope

When you connect your Homey back to USB and mount partition, do you still see the files ? It might happen when you unmount drives incorrectly, files do not get saved.

I’m trying, and I’ll let you know.

It works:). i didn`t know that sandbox had to be activated in homey. Thanks:) I think i have tried 30 times.

Are you sure you didn’t copy the files to BOOTA and BOOTB?

Also, why exactly do you want to jailbreak your Homey?

The sandbox is something else and unrelated to the topic of this thread.

1 Like

Should I deactivate San*** now after i have finished a to expand memory on a CM4?

More memory :slight_smile:

With the SSH experiment you’re not logging into the “real” Homey, so any changes you make in it are useless.

I also don’t understand why you need to make changes for more memory, Linux will take everything it will find automatically.

I`m not using SSH experiment,I simply enabled the sandbox so that the files in ROOTA and ROOTB would be saved. I couldn’t do it before I did that. Now OPEN SSH works on Homey. And now I’ve expanded the disk and memory. (CM4108032) innstalled.

Then I have no idea what that even means :man_shrugging:t3:

Hi, will jailbreaking give me access to the code of the installed apps on Homey? I want to see how certain Ikea devices are implemented in the official app.

Thanks!