Matter switch setup failed at last step. Now can't find device

I have a TP-Link Tapo light switch (S505) which uses Matter to connect. I installed the switch. I ran through the setup on the Homey App by scanning the QR code. The setup ran through all the steps successfully, and the switch’s light changed, showing it was configured. But at the end of the setup, when it says “Adding matter device to Homey”, it gave a timed-out error and kicked me out of the setup. Now it will no longer detect the device. I even did a factory reset of the Tapo switch and Homey still won’t detect the device. I had something similar happen with the same brand of switch when I first set up Homey. I fixed it by factory resetting the Homey Pro. I’d like to avoid doing that again and setting up everything again. Is there another way?

Which instructions did you follow?
Did you use your Mobile with bluetooth enabled in range of the light?
These are the Athom instructions:

I did have a mobile with Bluetooth enabled near the switch, but I followed the instructions for adding a Matter device. I added a new device to the Homey mobile app and chose Matter. Scanned the QR code. After continuing to play with it, I tried installing the Tapo app on my phone and added the switch to the app successfully. Then I removed it from the app. After that, Homey will see the switch again. I go through the Matter setup process and get all the way to Device Connected. When I press Done it says Adding Matter device to Homey. Then Unable to connect. A timeout occurred. Then I’m unable to connect to the switch until I’ve added it to another platform and removed it. I’ve repeated this four times with the same results each time. Homey version 10.0.8

1 Like

Hi Brian, thanks for the explanation.
If you didn’t already, I would file an issue with Support | Homey and share your findings.
Because this is not user solvable imho.


I think you’re right. I have two others of the same switch that in the past connected fine via Matter to Homey. I removed one and then tried to re-add it and ran into the same problem. I’ll report it. Thanks for the attempt.

1 Like

I have the same problem with a tapo P110M. Did you manage to find a solution?

If I do a native matter install (qr code) it can’t find the device. If I first add it to the tapo iOS app, then add to Homey, it’s found and says it’s added. Then the next screen says adding to homey, but it fails.

1 Like

I wonder. Research suggests that Matter will only work over IPv6. My LAN is an IPv4 only network. Is it possible that Honey only supports IPv6, and that’s why it’s timing out?

The tapo app works fine, but it may be able to support IPv4 in some kind of compatibility mode that Homey doesn’t support.


Here’s some insights on Thread by Emile

Once the device is connected to your existing Thread network, anyone can talk Matter to it, because it’s reachable over IPv6.

That makes sense over Thread. But I think my matter tapo devices are Matter over WiFi, not over thread. And the tapo app controls them ok on my IPv4 network.

I hadn’t gone back and researched. All work through my Tapo app. The odd thing is, it worked when I first got my Homey and I’ve only run into this problem after getting some more Tapo switches.

If I use your tapo app, will that use matter or will it use a cloud api? I don’t want to be unable to control if the internet goes down.

Well, the IP version is not Thread related, while it seemed to say to me, Matter over Thread uses ipv6 (which is used @ IP networks)
So, I would expect Matter over Wifi also using ipv6, don’t you?
Which won’t work with your setup?

Yes, I know" Thy should not assume, and thy should not expect :sweat_smile::stuck_out_tongue_winking_eye:

What Tapo app btw. I don’t find anything when I search for tapo on the honey pro App Store.

Hi together. I have 2 TAPO P110M being now succesfully integrated via MATTER QR Code to my Homey pro. BUT :slight_smile: Homey Pro does not show energy actual consumtion for what these smart plugs are designed :frowning: So I can see if the plug is ON/OFF but that´s it. Any ideas how to measure consumption in Homey with TAPO P110M ? Ofcourse I have this possibility in TP LInk App but you know, wanna have it on one place and that is Homey. Thanks

Probably the Matter protocol does not support energy measuring yet.
Homey’s Matter implementation does not support it yet for sure, but, it’s a work in progress: