Is there really no working Thermostat Valve to connect directly to Homey

Have tried a FIbaro FGT-001, didn’t get it working which was confirmed by quite a number of community members.

Have tried an Eurotronic Spirit Zwave, connected nicely but couldn’t send commands from a flow.

Considered a Danfoss, but this doesn’t support the readout of temperature

Asked advice at RobbShop, no other answer then I could try the Netatmo, as they said this ‘may’ work

Have asked Plugwise for advice but they recommended to only use Tom when also having a Adam

Finally browsed the forum, but can’t find consistent answers.

So getting desperate now…Al I want is a Smart Thermostat valve that I can connect to Homey without an additional gateway. It should support reading temperature and setting a temperature.
Any recommendations??

homey model early 2018
Homey version 7.1.4
App version 2.2.0

Did you try to add the eurotronic spirit zwave unsecure, this way?

Reset the thermostat to the factory settings.
Register a new device at Homey now.
Use the Fibaro Walli Switch as the device to be trained. Don’t worry, Homey will still recognize the spirit correctly, but include it unsecure.
You can see it in the developers that behind the Spirit entry is “Secure (x)”.

(Thank you undertaker! :slight_smile: )

It works for me, but the temperature is controled by an aqara sensor because the temperature sensor on the valves are not good enough for me.

No i did not.
As you can read here that is also not the answer

So, instead of going on with your original question you just start a new thread.
And i can’t read if you even tried the workaround.

Since the introduction of Homey FW 7.x and the Z-Wave security standard S2, the Walli method no longer works.
A new method to include Z-Wave devices insecure is to enter 00000 instead of the original PIN code at the pin request. This only works for devices that request a PIN code during inclusion (S2 authenticated devices).

@Frank_van_de_Schuur the POPP thermostat (Z-Wave) supports temperature read out:

Btw, in my opinion it’s not recommended to use the temperature of the thermostat. It’s better to use an external temperature sensor.

Thanks @DirkG thats constructive and helpful feedback.

For me adding as a walli switch worked two weks ago.
And I am on 7.x.x since it came out.
That’s why i asked if it was even tried…

Have you looked at Tado salves. I have them installed and control them from Homey.

The requirement is:

I use Danfoss LC13 Thermostat valves to set the required temperature and use an Aeotec Multisensor in the room for the actual temperature. Both connected directly to Homey.

I use the Eurotronic with flows, no problem.

Zigbee or zwave?

Z wave

It may be worth waiting for Zigbee thermostats to be integrated. At the moment I am using 4 Zigbee thermostats (Tuya and Danfoss Ally). Unfortunately, the integration is only possible via the Conbee Stick at the moment. The Tuya app will get an update shortly, which makes it possible to use it without an additional gateway.
The Zigbee thermostats work without any problems.

My experience with Zwave devices:
Danfoss/Devolo LC 13 is the most reliable device on the market. It can be very simple and has few functions, but it always does what it should. Caution ! The Danfoss/Devolo cannot process temperatures from external sensors.

The Eurotronic Spirit is a total disaster. Depending on the software version, it sometimes does not accept commands or heats uncontrollably and turns your room into a sauna. The thermostat has so many errors that you don’t know what to report first. If you are still brave, you should integrate the thermostat unsecure, otherwise more errors will occur.

I have very good experience with Danfoss Ally - quality product, precise and silent. So I would be happy if this thermostat will be integrated in Homey. What is the process of the integration? Should there be any request to Homey or Danfoss? As you mentioned: “It may be worth waiting for Zigbee thermostats to be integrated. At the moment I am using 4 Zigbee thermostats (Tuya and Danfoss Ally)”.

Trying to connect POPP Zigbee thermostat valve (POPZ701721) directly to Homey Pro without luck (have tried all the basics, reset zigbee network on Homey, close distance etc.) It’s now pretty clear that the POPP Homey app does not support Zigbee, only zwave. I’m curious to know if someone is aware of a workaround, via gateway or other solution to connect this device. (I was hoping to start a larger zigbee network with several of these, directly connected to Homey, but know I suppose I need to fall back to Zwave). Or maybe there’s another supplier that supports Thermostat Valve with direct connection using Zigbee to Homey?

There are no working Zigbee thermostats for Homey yet.
However, I use some Danfoss Ally and Tuya Zigbee thermostats via the Home Assistant or the Conbee 2 USB stick.
For the thermostats, I have created scripts in HA for the respective temperatures, which are then called up by Homey as needed.

There are two Apps available to control Plugwise stuff thru Homey; one operates via the Adam gateway the other without the gateway. I use the first App (and the Adam) coming from Spirit zwave valves. Happy with the reliability and stability!

Perhaps find a way to test the Homey app with a TOM / Koen without the Adam gateway.

FYI: the Walli method forced S0 security devices to include unsecure. But under Homey firmware 7 and higher S0 is no longer activated by default. So if your device is S0, The Walli method will produce the same result as normal inclusion.

If you want to prevent S2 security from being applied, enter 00000 as the pin when that is asked. If the device does not ask for a pin, [APP][PRO] UnZ-Cure (add z-wave devices unsecure) will work similar to the Walli method.

Sorry to be a smartass, but I could have told you that before. :man_shrugging:t3:

Please contact POPP and ask for adding the POPP ZigBee thermostat valve.
The hope is the more users ask for it, the earlier it may be added.