Invalid node id after migrating

Hi! Just migrated from 2019 to 2023 Homey through a backup.
Everything seems to be transfered OK, but there is an issue with all my Fibaro devices.

If I try to trigger a fibaro unit, I get the error: Invalid node id. Any suggestions on how to fix it?


Can this be related, Stian


i got same issue after migration 2016 to 2023.
waited more then an hour after restore. then after restart apps were started but when i try to use zwave device I also get invalid node id

Please do contact Athom on their support form, they might read these messages, but there is also a big chance they wont.

And lets not try to combine all issues that seem the same, to also be the same.
It could be related, but that doesn’t necessarily makes them the same.


Athom support adviced me to install latest experimental update and do restore of a pre backup. Then they would remotely run some scripts to do a fix. Since I only had a homey2016 backup i restored this one again to homey2023 with the experimental update. After restore my zwave devices were working again, without need of Athom support to run scripts.


Last weekend I installed a new Homey 2023, because I couldn’t reach the Homey 2019 anymore. Placed the back ups frome the old one and have the same troubles with the Z-wave devices . Does it have to be specificaly the back up or does anyone have another option?


you should be able to use backup made with latest stable firmware. Restore and the rebuilding all devices takes quite some time. Have you tried reset the 2023 and do a restore from 2019 again?

Hello Jan,
Thanks for your quick reply.
I shall try to restore to an earlier updat/back up than latest.
Could make sense, the 2019 had problems with latest one.
I’ll try it tomorrow.
Thanks, will get back to you.

Hello Jan,
Sorry for my late reply.
I re-installed the homey with an older version, that worked on the ‘19’ , now it works.
Hue gave some problems, re-installed them to and now it’s fine.
Thanks for your help.