Zwave of my Homey Pro Early 2023 stopped working

Today I had some internet problems at home, with my external connection, due to isseus with the provider. My Homey is wireless connected and at a certain moment I discovered that I could not reach the Homey while I was at home on my own network.

I cut the power of the Homey to try to restart it, but still no way I could get it back online. Only after going into setup mode and re-establishment of the wifi connection the Homey came online again.

Afterwards I discovered a few problem with some apps, so I restarted the Homey (from within the app) and updated to RC64.

But now I don’t have any connected zwave devices anymore. As soon as I try to send commands to them I receive an error: “invalid node ID: xx”

Restarting again does not solve the issue.
Anyone know where to look for the solution.

1 Like

I’m afraid that nodes were removed so you will need to pair evening back and fix flows :frowning:

Before I go change things, is there a way to confirm this?
Would a backup resolve this issue?

Yesterday evening I spend 4 ours programming new advanced flows. I really wouldn’t want to restore a backup as then I will loose al my new flows. But I also don’t want to reconnect al my zwave devices.

Not only because that would take a lot of time, but also because then I won’t be able to switch back to my old (stable) Homey in case something goes wrong again wit the 2023 Homey. (Of course my old Homey does not run at the same time to prevent zwave conflict).

It would be a serious issue if nodes are randomly removed. So, let’s not jump to that conclusion that quickly.

Just sent Athom A support ticket.

This is life-saver in such situations, using very often thanks to test/migrations/re-migrations…

So let us know, what you will learn. Basically you will see nodes and the status here - Homey Developer Tools - in case you see it as Route = Unknown, the device it’s either powered down or left the mesh.

1 Like

All my devices are still visable in “devices” area of the app, but in the Developer tools area I only have 1 zwave device (and that is the Homey itself).

I turned of my 2023 homey to check the situation in my old Homey (and to make sure that it is not a zwave device causing the problems). And then I see all of my zwave devices.

I am now in doubt if I will restore an older backup (and loose all of my newly made flows), or if I will try to reconnect my zwave deveices (but then I will loose the possibility to go back to my old Homey as backup).

I would repair everythin on HP2019 and then again restore on HP2023… because already looking on your HP2019, something is nit alright - eg. search for “Uknown”, you have both devices and routes uknown, which isn’t good…

BUT, this isn’t standard, when I analyzed HP2023 logs, seems there are plenty of ZWave errors as well, so I would probably wait another week or two, if Athom fixes also ZWave

I had no zwave problems on my old 2016 Homey. Maybe those old errors came after an error while removing some old zwave devices.

I have made a service ticket for Homey, so I hope they can help me somehow.
But, as I cannot turn on my TV or lights rigth now I can not wait for that solution, so I decided to take some steps trying to fix the problem. I logged my steps so I can trace (and undo) my changes.

I think I can make 3 conclussion out of this.
1- Probably it is not a hardware but a software problem
2- Probably the problem was created after I went into the setup mode. Then Homey23 f*cked up al my nodes.
3- My Homey23 backups do not contain zwave node data, or, it is not being restored after a bakcup restore. As the newly added node is still in my Homey23 after I went back to an old update (as an unknown device).

I tried your approach just now.

  • First reset my 2023 Homey and loaded the 2016 Homey backup into the system.

That gave me the same errors as the very first time I used this backup for my Homey23 (so all normal flows where missing) but… all zwave devices worked.

  • Then loaded the backup of my 2023 Homey I made earlier today (the one without the zwave nodes).

After this everything worked fine! All my nodes are back! All my flows are still there and working!

1 Like

Just to be sure, you are on latest HP2023, firmware version 10 RC65, right?

I am running RC64, also see my list of steps.

When you reload a backup from the time of an older firmware version, the firmware on the homey is not changed.

RC65 is not available yet.

Strange, it is (also have it installed on my HP2023) :

You have to enable Experimental updates in Dev Tools (Settings).
In previous versions Eu didn’t have to be enabled, but I don’t know why.

Thanks now I understand why I’m stuck at 64

Hm, interesting, I thought whole HP2023 is still in Experiment(al) mode :wink:

I have my hole home running on my 2023 Homey, so I’d rather stick with the “proven” beta-firmware then the expirimental firmware ;-).

I would prefer not to have these kind of issues again as it is a lot of work to check, fix and repair all issues after every backup restore.

I guess you don’t really mean it serious, and I know “Don’t touch a running system!”.
But there will certainly be many more experimental firmwares to come, I think at some point you’ll have to update your firmware too. :wink:

I have my updates set at Auto… so it updates as soon as there is an update.
Just not the experimental updates… as I need a stable system.

Autoupdate is not a good choice, not even for official updates. If something goes wrong during the update, e.g. at night or when you are not at home, you will unexpectedly have a problem. That’s why I always recommend to run an update only if you can react to it immediately in case of a problem.
When a new FW update is available, you will be notified on the timeline.