[HOW TO] View your Homey v2 flows in a browser

btw: i can also find my homey IP by looking in my router… will that do?

That will do

I had som problems with loading all flows, as @Anton also had.
It seems to be a problem with a parameter for a flow.

It worked, if I inserted this line after 444 in flowview.html. However, it should be solved better.

if (argDef === undefined && typeof value === 'number') argDef = {type: 'number'}  //todo: v2 workaround

No, you don’t need to be at home to be able to use this, but when not in the same network as your Homey you need the Athom Cloud uri and homeyID to connect.

I’ve changed the first post, now it tells you what to do when using a Local Connection and when using a Remote Connection

(The settings for a Remote Connection will also work when using a Local Connection)

What is my

Athom Cloud uri


This: image as it is described in the opening post of this topic.

1 Like

That will not do, the fact that the IP is not shown is because he is not connecting from the same network as his Homey is in, so it’s highly likely there is no possibility to connect to the local IP address.

1 Like


Gave up trying te get it working remotely (and had to work a bit :-))
Came home, punched in homey’s internal adress and HURRAY IT WORKS

KUdo’s Kudo’s Kudo’s for you!! :heart_eyes::heart_eyes:
judging by all the griefof users with Athom’s choice to abandon Web- & PC support in V2…

I think you made a lot of people happy.


This has got to be the single most important “App” right now.
Thank you @Erik for the code and @DaneedeKruyff for the guide.
Make creating/editing flows possible (i know its no that easy) and you can have my firstborn… or a large beer if you prefer that :slight_smile:

1 Like

Don’t thank me, I just wrote the How To. Thank @Erik, he did the real work!

I never get the local ip, even if I am on same network. I can only see it from the API playground (or just on my router)

Ok, so in your case retrieving the IP address wouldn’t even enable you to connect Homey 2 flow viewer to your Homey.

I suggest reporting this to Athom here because that’s not intended behaviour. In your situation you wouldn’t be able to connect to your Homey when the Cloud services can’t be reached, not something you want.

See this topic

I’ve wrote an editor for private use in the past, need to do some basic work on the code first and look into editing after that.


I think we would all appreciate if you could release it…

Consider putting it on GITHUB with a disclaimer showing its unfinished after you strip out any personally identifiable…

I get the sense that many on here would jump to assist getting it release or merged in this viewer

1 Like

My error:

Uncaught TypeError: Cannot read property ‘order’ of undefined
at folderOrder (flowview.html:563)
at flows.forEach.flow (flowview.html:583)
at Array.forEach ()
at showFlows (flowview.html:581)
at loadTokens (flowview.html:631)
at Object.success (flowview.html:558)
at i (jquery-2.2.3.min.js:2)
at Object.fireWith [as resolveWith] (jquery-2.2.3.min.js:2)
at z (jquery-2.2.3.min.js:4)
at XMLHttpRequest. (jquery-2.2.3.min.js:4)

Just a note, I was searching for a 144 character bearer code. My bearer token is actually 114 characters long.

Thanks for the write up! A nice tool. I am using the external https atom method and that works like a charm. A bit rough around the edges but a very nice addition to my tool set. Most of all I liked the possibility to, although a bit crude, print my flows. If three people stepped out of the office and went into a field and going all apesh*t and stamping on my homey, at least I have some sort of a paper trail documenting the active flows configured at the moment. A backup, for piece of mind, by lack of a backup tool.

Works great. Thx @DaneedeKruyff and @Erik
My bearer token is only 114 characters long.
May be confusing.

I downloaded the latest version last night and I was missing some flows I did see in the version I downloaded at/around 21-1.

In the dev-console I had two errors:

  • no app found for card actions homey:device:4b15be7f-36c3-4882-b931-7e6fbfd9eae5
  • Uncaught TypeError: Cannot read property ‘filter’ of undefined

I updated line 436 in flowview.html with the one below to solve the ‘filter undefined’ issue.
if (localTriggerCard && localTriggerCard.tokens && localTriggerCard.tokens.filter) token = localTriggerCard.tokens.filter(x => x.id === token.title)[0] || token

It solved my display issue and now shows all flows, but gave a bunch more errors:

  • no app found for card actions homey:device:4b15be7f-36c3-4882-b931-7e6fbfd9eae5 @flowview.html:380
  • no app found for card actions homey:device:4b15be7f-36c3-4882-b931-7e6fbfd9eae5 @flowview.html:380
  • no app found for card actions homey:device:4b15be7f-36c3-4882-b931-7e6fbfd9eae5 @flowview.html:380
  • no definitions found for card trigger homey:manager:mobile @flowview.html:375
  • no app found for card actions homey:device:9f2bdd4e-77bb-43df-8096-ec3e4882e22f @flowview.html:380
  • Not initialized, can not call method : remove @flowview.html:11

How can I find which devices and flows these are? Are these the broken flows?
I used the API playground but I can’t find these devices when searching Homey.devices.getDevices(); (which is probably the whole issue :wink: )

I must say, I took the 144 from the text in the config.js untill now never counted the actual number but I guess you are right. I’ll edit the opening post.


1 Like

If it is possible to make this viewer an editor a lot of people missing the webbrowser should be Very happy again :sunglasses::grinning:

1 Like