How to set a simple timer reset

Hi guys!

This question was discussed a lot of time here but I cannot get it work.
What I want to do is simple. When light is on and area becomes inactive → start countdown to turn off the lights BUT reset the timer when movement was detected after the area became inactive within the timer time.

I tried to use two different apps without success. Now I try to get it work with the Cronograph app.
My problem is that it doesnt matter what time I set, it is ignored by the app and simply triggers the next action right away ignoring the time I set.

Could someone tell what I´m doing wrong, please?

I created a short flow as attached. When the area becomes inactive, the timer doesnt start but triggers the next event instead.
I can attach tags to the field “Name” but do I need to and if yes, which one? Same for “Duration”.

Again, sorry for asking a question that was discussed so many times here but I start to dispair.



Maybe you can switch (temporarily) to normal flow and use “when zone is inactive for x minutes”. I have not used extended flows, so I don’t know if this card is available in your flow.


Thanks for the hint.
This option is also available in advanced flows and is some kind of a solution but there you can only add minutes. In few specific cases I need to set seconds as a minute is too long. So, I thought a timer app would help but I cannot get it run correctly.

Then you might use the card “when zone becomes inactive” and use the delay in the card switching of the light.

Try replacing the nam “Test / 10s” by “Test_10s” to get rid of the dash slash. As this might be a special character.
When you click on the “i” you get information how to use the card.

I use the app countdown. This works perfect and I use your setup. In the configuratian. you define a time (for instance lightstimer)
In dutch the cards are named zandloper.
Then the flows are
IF THEN <start zandloper ligthstimer 180>

I use a variable which i use in a different flow to kill or activate the lights

In this topic you’ll find several examples and variations

The problem is that you gave the timer 2 different names: Test and 10 s
Either use the drop-down menu and select an existing timer, or enter a name in the Name field:

It doesnt work. Once it detected inactivity, the delay starts and turns off the light disregarding any motion happened during the delay time.

The “/” cannot be removed. It a part of the card.

I dont know how to get the Countdown app work. It doesnt matter what delay I set, it turns off the lights after few ms. Same happens in Chronograph app.
As others work with it, like you, there must be a mistake on my side and I try to figure out what it could be.

Do I add the timer, give it a name set the time? Is it all or do I have to specify something else somewhere?




When I leave one of the field empty it gives me an error and I cannot save the flow. I have to specify both.

Best regards


Believe me, only 1 field needs to be used.
Please delete the flow card, save the flow and add the card again and only fill in 1 field.
If you use several Chronograph flow cards in the flow, please do this with all flow cards.

If an error is displayed, please take a screenshot and post it.

Hou have to go to the app. In configuration you defilé a timer

So this problem is solved?

Hé Alex, it looks you are reporting about 2 different apps. That is complicating the discussion in here, as I have a very limited view of your system.
So I suggest to make the most simple flow to test the timer. Start a flow manually, make a delay and switch on a lamp after the delay, or send yourself a message. Then share you flow and results here.

Back the beginning. As the clicking on the i-button of the cards says: enter a new name for a new counter, or select the name of an existing counter.
In normal flows it looks like:

So from your picture it shows you have done both, you have a timer “Test” and a timer “10s

This is how it works with the countdown app you are using. This option is not available in the chronograph app that he uses. You can simply enter a timer name in the “Name” field, or use the “Pick” drop-down menu to select an existing name and/or create a new timer name.

This is what I have already mentioned here:man_shrugging:t3:

And even that might not be the problem, as I just found out that the “chosen one” is leading. However, the only way to find the problem is to exclude all possible causes.

Okay, I didn’t know that. When Arie added the picker, at first I also used both fields, but with identical names, and that worked too.

However, it makes no sense to speculate further here if @Alex_S1 doesn’t give us any feedback, including the error notification he receives when he uses only one field.