Homey v2 and emulators

Since Athom announced they had to focus their resources on one interface and that interface would be mobile, there have been lots of heated discussions. However some of us may be sorry about the path they chose, it’s something we have to deal with. Now v2 is in preview we can start .

I tested a number of emulators and I’d like to share my experiences. Most important to note: The main part of the Homey interface does work on android 4.x but things like pairing new devices doesn’t work most of the times: The overlays on the buttons don’t work, for that you need at least android 5:

All emulators I’ve tried work in landscape like tablets and as soon as you start the Homey-app, the screen changes to a portrait-size. So it’s like working with Homey on a phone.

1) Bluestacks 3/4
This is the best-known emulator for android and available for windows and mac and honestly I’m wondering why. I had Bluestacks 3 installed which was on a 4.x version of android:

This was a bloated interface in which one has to search for a way to go to the appstore and install the Homey-app. Apart from that, it looks like it was consuming lots of CPU from time to time. But fortunately Bluestacks 4 looks less bloated though the CPU-usage is still high…
available for windows and macos
website: https://www.bluestacks.com/

2) Andy
The Andy-project seems to be on a bumpy road, at least it stopped working for me and the latest download doesn’t install. Didn’t test this any more…
Available for windows and linux
website : https://www.andyroid.net/

On a lot of places it says this emulator has stopped developments. But nothing about that on the website, looks like it’s still supported. Processor-usage is low but android 4 so not everything in the app works. I like the processor-usage but it’s outdated.
Available for windows
website : http://www.amiduos.com/

4) NOX
A clean interface with a lot of possibilities but watch out, out of the box : android 4
One has to select the “multi-instance” and then install a new “virtual machine” with android 7.1.2. From there, you can also create a shortcut on the desktop. Just delete the standard-instance of android 4.x
Available for windows and macos (though no multi-instance so no android 7)
website: https://www.bignox.com/

5) MeMu
MeMu is almost a copy of NOX but harder to install, at least I couldn’t get networking going in the standard 4.x android instance. Also: MeMu look like it’s targeted to playing games. Just as in NOX player there’s a multi-instance manager from which one can choose to create an android 7.x machine. Networking in android 7.x worked directly but maybe that’s because I installed some extra network-drivers in 4.x. Unlike in NOX, the multi-instance manager is available directly from your OS.
Available for windows
website : https://www.memuplay.com/

6) APK-online
If you want to stick to your chrome-browser, one can use apkonline. It’s running android 6 in a browser but no appstore. You have to download the Homey apk from your mobile or a site like https://apkgk.com/app.homey
Available : browsers
website : https://www.apkonline.net/

7) Genymotion
This emulator is not for free, 99 dollars per year after the trial-period. No appstore to install from so you need to upload the apk. Big advantage: there’s tons of formfactors and android-versions to play with:

Available for windows
website : https://www.genymotion.com/

8) Android Studio
Like Genymotion lots of options. See the addition of @Robin_van_Kekem for more info here.

If there’s better (more userfriendly, less resource-intensive etc) emulators, please let me know…


for future use

NOX for Mac OS X does not support the multi-instance option and therefore you’re not able to switch to Android 7…
if someone found out a way to get this working, through e.g the Java Virtual machine, I would appreciate it.

Currently using BlueStacks 4 on Mac OS X with best results.

1 Like

There is another option:
The build-in emulator in Android Studio (available here: https://developer.android.com/studio/install).
This is the official IDE (Integrated Development Environment)

Using the emulator:


  • Official Android emulator
  • Differtent sizes and tablet emulator
  • Hardware accelerated
  • Every Android version you can think of
  • Play Store available
  • Auto update apps
  • Many manuals online
  • Touchscreen support
  • You can try the latest Android version :sunglasses:


  • Large! (Like in several Gigabytes large!)
  • No play store version for tablets available (if you know your way using ADB, you can use the tablet)
  • Not for every hardware
  • Not an easy click-and-go setup

The new version app and homey v 2.0 (Early 2019) are not working correctly on Nox and MeMu.
The issue I have is After adding a new Device, then install button the screen goes blank (White), For a second I see the load icon and it seems the app wants to load a second screen specific to a device and then blank , I can only go Back.

Happens to all Sorts of device, Spotify, Ikea, Toom etc.

Nox emulator android 4
Memu android 5

Has Someone seen this issue

Memu with android 7 emulator seems to work, Keep in mind that you need a bridged connection
go to settings (Right menu from device, ), Network Tab and set it to … Bridged connection.

Also Install the Chrome browser, the build in does not work when clicking install for the apps on Homey.

Bridge connection with nox 7 did not work for me, did not connect to my local network

I’ve had that sometimes too. Clearing cache seems to help (didn’t do that myself) but deleting and re-installing the app does. Also you need to have an android 7 instance via Nox Multidrive.

For those who have a samsung phone: https://www.samsung.com/nl/support/side-sync/

1 Like


I can not check it on Homey yet but for Smartthings I use Phoenix OS.
I did not find anything more friendly.

I do not get the android emulators going. every time I click on the new map in the flow editor, the homey app closes. someone who can help me further? I have tried nox android 4 and 7 and I have tried bluesteak but with all the same result

I did not get Nox to work with my local network, So I cannot test this, The Memu with android 7.1 works without issue’s. It can also be the browser that is used on Nox, Chrome seems to work best.

“Keep in mind that you need a bridged connection
go to settings (Right menu from device, ), Network Tab and set it to … Bridged connection.”

Just a heads up, GenyMotion can be used for free when opting for personal use:

Also be aware for MeMu and Andy! Both seemed to have installed cryptominers in the past! For example:

Unfortunaly the world of Android emulators seems very shady in general. There are dozens posts on Reddit, but this is a good summary: