Homey seems to be wrong by 1 hour since the clocks changed last night

I am new to Homey so set up a little flow to turn the lights off at 10pm and on again the next morning at 7am. Today however the lights came on at 8am, presumably as at 2am the clocks moved back an hour for daylight saving.
I am surprised that Homey didn’t automatically adjust for the time change as just about all other net aware clocks did. Am I missing something? I looked in settings but couldn’t see anything about setting times. Could the time be controlled by the location of the device?

Yes, I suppose so.
So you have to activate “Set my location automatically” in the menu: More -> Settings -> Location.