Homey+ Restore


Suddenly all my Zigbee devices have disappeared from the list. Fortunately I have subscribed for Homey+ and have enabled nightly backups, the last one made last night. Now I would like to do a restore but have no idea how to perform it. From the iOS app I have looked under the Backups section but here I can only force a new backup, I see no restore option.

Can anybody guide me how to do a restore?


Hi Caseda, thanks for your reply.

When I follow the guide the Homey enters the recovery mode just fine, but I only have the two options “Keep your data” and “Reset to factory settings”. I am not asked if I want to restore a backup as mentioned in the guide. I have checked that I actually have 7 backups online so this part should be fine. I’m a bit reluctant to choosing to factory reset the Homey because I fear that I will have a lot of work to do installing apps and device and configuring and creating flows.

I performed all steps on my PC. Isn’t this the correct method or do you suggest to do it another way?

Thanks again,

You first need a empty Homey to restore a backup. Could also work from the mobile app, but web from pc should work.

Thanks, Dijker. It worked to select the factory reset option whereafter I was able to choose to restore one of my backups.

The reason why I needed to restore in the first place is because I suddenly lost all my Zigbee devices, mainly window sensors and a few buttons. After I did the restore they all appear again, but, now with an exclamation mark on them. When I select one by pressing the icon it says “Unknown error”. When long pressing it says that the unit is not available (translated from Danish). I have more than 20 sensors, so I prefer not to have to remove them and add them and rename again, but is that the only way to have them operate again?


Leave your Homey running for a good few hours to see if it solves itself. If not, try a Pull-the-Plug for at least 10 minutes and try again.

Thanks, robertklep. I will try that and return with a status of whether it worked or not.


I left the Homey running for about 5 hours, turned it off for 20 minutes and then on again but it’s the same. I have also tried to reset the Zigbee interface without luck.

I feared to end up in this situation where I have to delete all devices, add them all again, rename and group them and redo all my flows. That´s why I bought the Plus subscription but unfortunately good for nothing.

Thanks for your help Dijker and robertklep

You really did a Reset of Zigbee? I guess you didn’t understand what that means!

Then you removed all Zigbee device.

Please Restore a Backup from Before you did reset it! (If you did not yet touch the Zigbee devices to reset them also.)

Hello Dijker,

I did the reset after the unsuccessful restore after which all devices still were still listed with “Unknown error”. After the recet procedure the devices were of course removed and I did a new restore with the same result - “Unknown error” on all Zigbee devices. After that I have added a new device successfully so the Zigbee interface works just fine.