Homey Pro Restart -> KNX Switch get triggered in flow

Hi everyone,
I added a knx button as a switch and created a flow that listens to the “on” status. If it get pressed the status changes to on and then the Garage opens. Afters 1sec I set it to off again.

Now I have a problem with this flow, because the Garage opens everytime the Homey Pro restarts.

How can I avoid this? Or is there a way to correctly add a knx button and avoid adding it as a switch?


I know it has to restart after f.i. a firmware update, but you make it sound you restart it on a regular base? That shouldn’t be necessary…

Not a solution, but you can turn off firmware updates, and install them yourself when you think you need it. And you can close the garagedoor right after that :grin:

Firmware updates are announced in the Timeline

No I was just wondering why the garage door opened at the middle of the night and found out that we lost power and the homey restarted. But when I am not at home it should not trigger the flow. I need a “cleaner” solution for this :sweat_smile: .

Maybe you can try the “OFF” status?

I changed some settings in KNX so that the status get to be set to off right away. This way it also works if homey need to restart.