Homey Community App Store

Hello :slight_smile:

I’m lost… I discovered yesterday (yes, I’m new :wink: ) that in order to install community apps (of which the “Install” buttons are all grey and not clickable) I had to install the appstore app. Did that and got confirmation but it’s still not working for me :frowning:

Can you help ?

I’d first need Google DSM (for my Nest smoke detector) and smartthings (for my Meross plugs)…

You’ll have to login, otherwise the site doesn’t know what your Homey is:
Hover the green ‘thing’ in the top right corner.
When you use a mobile browser, first set it to ‘Desktop mode’.

  • Click on the middle icon (a square with an arrow pointing in)

  • Click the blue button “Login at Athom”

  • After login, agree with “Allow Homey CLI to…”

  • Ignore the line “could not log you in”, but →
    copy the code which is presented

  • Go back to the previous tab or page of store.homey.community

  • Paste the copied code in the “Paste authorization code here” field

If all went well, your profile is shown along with your Homey('s) with all installed apps.
Now you can search for your wanted apps, the install buttons should be green now and your apps can be installed.
First check if the “Homey Community Store” app is running on Homey. The site can not check the install process, or if your Homey is available or not.
You can disable the HCS app when you’re done installing apps, but it has a nice feature: when you disable all auto-updates, this app notifies you of any available app update.

OMG :smiley:

It seems to work !!!
It took me a few trials to get it because it’s a matter of seconds before the code expires, so, guys, keep trying, you have to switch quickly between the pages :rofl:

Install button is now green and I tried both apps I mentionned earlier. Tells me I have to wait a little before it’s available, will see.

Thank you so much, Peter_Kawa !

1 Like

You’re very welcome, Pierre. Remember the procedure is ofcourse not to nag you, it’s just a neat, but a bit complicated, workaround to be able to install apps apart from the homey.app store :wink:

I’m having trouble logging in from HCS Homey Community Store.

What’s going wrong. I don’t get an authorization code!

What steps do I do:
-Homey Community Store
-press the blue button “LOG IN AT ATHOM” and login with my account at Athom.
-press the “Allow” button
Schermafbeelding 2022-12-28 002102
-Then I don’t get a code but I do get this screen

What is going wrong, why I don’t get an authorization code?

@Peter_Kawa already suggested here

to use Firefox.
Did you try and what was the result?

No, I hadn’t done that yet. I hadn’t read the addition firefox. But I did it now. And then it works. Thank you.

To add to this, I have often problems with the community store and Firefox is then not the solution, but gives me the same problem. Even refreshing pages, or close page and open page again, very troublesome.

This weekend I finally succeeded using Safari on my iMac, after trying Edge, Chrome and Firefox, which all were failing me, including Firefox!

This is then the screen I get and even pressing Accept all cookies does not work for me and pressing somewhere in the right above corner the menu flashes in/out and are not usable or are so slow that you need 2-5 minuts patients before something happens. Very odd and unstable for me at least (every time). But if I get it working it works, site itself is user friendly, but due to the technical issues I try to avoid it and rather have a git pull from a repository for an app.

I even succeeded once on a Tablet with Chrome, but that was once and never again after that.

Any news yet on the availability of installing apps from the Community Store on Homey Pro 2023?

When I run the compatibility script that checks apps for SDK 3, it says the Homey Community Store app (the one that is needed for installing directly from the HCS) is still on SDK 2… :frowning:

(Don’t know how reliable this script is though; it still marks the official Tado app from Athom as SDK 2, although the app store says it’s on SDK 3)

Correct, it is still SDK2,
they confirmed and are working on it. (Slack channel #communityappstore yesterday 13-01-2022)

Ah, thanks! Can’t find that channel.
Good news! :+1:

Thanks. I am already in Homey Users on Slack, but can not find channel #communityappstore
(sorry, not a very experienced Slack user here…

Thanks to @Rocodamelshekima I am in, thx!

I’m sorry if i somewhat post out of the subject… I just can’t seem to find a fitting thread.

But anyone else having problems these past days with installing apps from the community store? Atleast i haven’t been able to.

Tried logging in and out from website, deleting cookies, deleting the community app from homey and reinstalling. Whats left besides factory reset - which i really do not feel like doing.??

Kind regards Mathias


Yes we noticed this ourselves last Friday as well. Unsure what is causing it but we are looking into it. Thanks for reporting though!


@Mr_Meri Should be working again. A restart of the HCS app might be required.


Yes, I can confirm it’s working again. Thx, @MaxvandeLaar!

1 Like

Is it possible that the beta version of the Community Store app has issues with the settings / update pages? They are all empty here, while apps are installed. Also, updates do not seem to get through.

I reinstalled via the Mac tool and still the same issue. Version 2.2.2. I cannot download or install 2.2.1.

Working OK for me, so not sure what is going wrong.
Are you looking at the settings in the phone app or Developer Tools?