Homey app super slow on Android (Note 9), no real performance

Hi there, for a long long time, I encounter very low performance of my Homey app on my Galaxy Note 9. If I choose “Devices” fe, I have to really wait for a few seconds before I can select any of the devices presented. Even be able to scroll takes a few seconds. Sometimes the result is that i accidentally press a device which then goes on or off. :frowning: Same sloooooow performance by the way when navigating to the flows overview.

I have already restarted all, from modem, router to my Android. Re-installed the app several times, restarted Homey. No effect whatsoever.

I have no problems with the desktop version.

I will have a try on my wife’s iPhone and will share those results.
Update: super fast on an iPhone… So it’s either Android, or ‘my phone’ related…

My OS is up to date, Note9 is about 2+yrs old, No performance problems on any other app, only Homey…

Anybody some genius tips? Can I do something somewhere on my Android setting?

Thanks upfront,


Hi Michel,
I can confirm the problem. You don’t need to change anything in the settings, it’s definitely the app. I have different devices. It doesn’t matter whether it’s the latest Samsung device or an ancient Huawai tablet, the app is very slow everywhere.

Do not install the new Android beta app. The complete widgets will then no longer work!

Hi Uwe/Undertaker, thanks for your response. On the one hand it is nice to hear that it is not my problem alone, but a common one. On the other hand, it is a shitty problem :-(.

So it’s then asking Athom if they recognize it as well and are working on a solution, isn’t it?

Regards and enjoy your day, Michel

1 Like

It’s definitely the app and there have been quite a few users mention it.
I have found that keeping the number of timeline events low can improve the response time but it is not a complete cure.
It’s like the app tries to get everything from Homey when you start the app and that take a higher priority then the UI.

I hope Athom takes care of this problem in a timely manner because it is no longer fun to use this app. I have another Homey that I am setting up for a friend. There are almost no timeline entries here yet and it is as slow as mine though. The latest beta app makes it even worse. The app is just as slow and in addition none of the widgets work anymore. It seems that Athom is only busy with the unnecessary bridge and has no time for pro development.

My time line is small also. Just a few lines. As we all experienced, that is not the solution we hoped it could have been.

Dropped it at Athoms now. Let’s wait and see…

Thanks for sharing! Michel.

Confirmed. And it’s the case for almost a year now.

Many timeline entries slow things a bit down, but workable for me.

I noticed the app got real sluggish and slow, since v6.8.x (July 2021).
The (very nice) main new features were:
-the device-tile icons can be changed
-the status indicator can be shown and changed (for non-thermostat devices)

I ran some tests and v6.4.0 is really way more responsive.
BUT you’ll need to add virtual thermostats (and needed flows) again if you want to display status indicators and use custom icons…
If you want to test this, click - You can safely install pre v6.8.x apps, your preferred choices were saved with the device, and are displayed again when installing v6.8 and up.


Slow versions

  • v6.8.0 - 2021-jul-12
  • v6.9.0 - 2021-sept-8
    Even Slower
  • v6.9.1 - 2021-sept-20

Not so slow versions
(but without the changeable device tiles):

  • v6.4.0 - 2021-mar-19
  • v6.5.1 2021-may-04
    Even slower:
  • v6.7.1 - 2021-jun-11

I informed Athom @ Slack a while ago.

1 Like

This is the answer of Athom…

"Hi Michel‍,

Thank you for reporting this issue, and our apologies for your inconvenience!

For the moment there is no solution for your issue unfortunately. We are aware of this issue and my colleagues of development are working on a solution to improve the performance on Note9 devices.

For now this is the only thing I can do for you, which is why I’m closing your ticket. If you need additional support, please feel free to re-open your ticket by answering this email.

I wish you a great day and a lot of fun with Homey!
Best Regards,"

I think it is a no go. I will try to figure out what the priority is… Since the desktop app is not supporting full functionality, as Android users, we need a good working app! It’s vital in managing Homey!

To be continued…


Guess they missed the part that it is not only Note9’s that have this problem :sob:


I’m sure they just have an AI that will fill in $DEVICENAME in the answer :stuck_out_tongue:

This is what I sent to Athom as a response to their answer.

"Thanks for the response. I am however not satisfied with the answer. You at Athom choose to switch from a desktop app to a mobile one a few years ago. That was not my choice. In the meanwhile, due to members efforts, we have a partially working desktop app back, but it doesn’t support full functionality.

So, as a user, I am still reliable on the app I have on my mobile, which has a lousy response! So, telling me ‘We are aware of this issue and my colleagues of development are working on a solution to improve the performance” is not enough. I work daily to improve my home automation and I need a well working app to do so. Wherever I am!

And it is not only Galaxy Note 9, but also all Android devices! Look at the community response I have got in no time on sharing this issue there (first).

So, I need you to reopen this ticket and come up with a better and more concrete answer to when you really solve this issue. Bear in mind, for all those Homey fans like me, with a lot of smart devices, reliable on flows to work, where spouses are not that much into domotica, it is very frustrating to not have a well responsive working operating tool available! I suspect at Athom you all have iPhones. Change to Android for a few weeks, to experience what your customers experience daily.

To sum it up: Please re-open this ticket for me (for all Android users) and let me know when this issue will be solved. Work in progress is not an answer. If you as support cannot do anything more, please escalate this or let me know how I can escalate this.

Appreciate your efforts and thanks upfront,



Hi there, short update from the recent communication with Athom: I apparantly had a few unknown nodes, which disturbed my Z-wave network. I have deleted those nodes. Need to know how to do this? Let me know.

No performance boost however :frowning:

Still some homework to do, but I doubt this all will lead to a better performance.

Keep you posted.