Android Homey App unresponsive?

I have been struggling with this very frustrating issue for months. Even created a support request with Athom, but unfortunately no resolution was found.

In short: managing devices from the Android Homey app sometimes becomes really laggy & unresponsive.

  • Toggling between the Home/Devices/Flow pages sometimes just does not work
  • Long-pressing on a device it just does not respond, sometimes it eventually does
  • I have to kill the Homey app very often to get it going again (sometimes the “Retry” button will show up, and pressing it will reconnect successfully).

Observations:

  • Disabling wifi on the phone (using 4G) does not really solve the issue
  • It happens on multiple devices (e.g. Pixel 5 and Galaxy Tab S5E)
  • The web UI does not seem to have this issue at all!
  • No high system load at the time
  • The problem gets worse when roaming through the house (wifi mesh)
  • I connected Homey to another 2.4GHz AP (not mesh, not 40MHz channel width) which solved other issues (high latency/ping on the lan) and improved the phone app experience a bit.

The common denominator in all of this is the Homey App itself. It does not seem to handle client network changes very well.

So I am wondering: do others experience this as well, or is the app always responsive for you (IOS/Android)?

2 Likes

I’m right there with you. It’s becoming an insult how slow the Android app is. After the next update, it will probably no longer be usable.

Are you sure its the Android app and not Homey?

I also had similar problems. After disabling speech and deleting unused apps it was solved.

Yes, sure. The app is very sluggish and often does not respond to inputs. Clearing the cache improves the response for a few hours.
This problem occurs on all my Android devices.

I’m sure it’s the app, because:

  • Web UI always works fine
  • Restarting the app fixes the issue for a while
  • Average system load is normal (<1)

When I start clicking around in the app after a restart, it will get laggy again within minutes.
:frowning:

BTW: I am pretty confident that Homey 2023 will solve all of this, but still it’s still very annoying for now! I really would like to hear from Android users that do not experience this issue so I can rule out an issue my local setup.

@Undertaker Do you also use the Deconz app? All my 50+ zigbee devices are managed by Deconz, and since it’s using a websock connection over the not-so-great Homey wifi connection, it might be related to that (although I would expect something similar with other websocket based solutions like HA)?

Yes, I also use Deconz. But it’s definitely not because of this app. I have a second Homey without Deconz and the Android app is just as slow.

1 Like

Does the other Homey contain many devices? And if so: are these devices connected directly to Homey or also ones that are updated using wifi (e.g. 3rd party App using websocket)?

With the other Homey, no device is actually connected directly. It fetches its necessary devices via MQTT, HA and is only intended to bridge longer distances via wifi.

Edit:
I know other Homey users who have exactly the same problem and have only registered devices via Zwave and Zigbee.

To be honest I don’t expect this to be solved with Homey 2023 just around the corner, but I would at least like to understand what causes it! To me the slick App was one of the reasons to choose Homey, but I can’t trust it in many cases unless I force close it first. :neutral_face:

I hope on Homey 2023 with the Pi4 compute unit we will be able to do more troubleshooting ourselves, because it’s frustrating we don’t even have access to basic logs right now.

Must say I do not recognize these problems in my Android (12) Samsung S21+.
I agree the app could be a little faster, especially for starting up, but I have no problems with unresponsiveness or not opening tabs…
What if you try the app on another phone, if possible?

I just to have a lot off lag.
Solving wifi issues made most of my android app lag go away.
A solid wifi is very important to Homey.

Also, do you have many AVDs for which you change the text-status-indicator?

Yep, i had this too, tried too solve it for a year.
Turned out i need to put my 2.4 ghz wifi to fixed 20mhz, and that solved the issues you are describing.

Now the app actually runs increadable fast and solid.
(And i would have not believed it if someone had advised me back then)

So at least it works for some others! :slight_smile:

When I initially start the app everything is fine for a while, so I don’t think it’s related to the amount of devices/updates (no AVDs). It’s only after I start navigating/scrolling on different pages for a minute that it starts to lag (sometimes with “An unknown error occurred” + “Retry” button, and it remains that way until I restart the app. I haven’t tried another phone, but on a completely different tablet the same issue.

I have a very stable UNIFI wifi that runs at 20 MHz/2.4 and 3 access points. Homey is 10 cm away from an AP. I don’t think that is the cause.

Hi @JeeHaa

I experience exactly the same. I have sent in a ticket for it recently (some months ago). End of the story was that Homey is aware of this issue and is working on it. They did not have any real tips or trics that could improve performance and make it useable (like any other app in the world :wink: )

With the Advanced flows delivered, and the new Homey Pro almost ready, I realy hope that the Android version of the app is the next priority!!

So I agree and ‘suffer’ with you…It is unworkable!

We need to hang on in there and then one day…

So, hang on in there! Michel

1 Like

The strange thing is that sometimes the app works fine for a while (e.g. after a Homey restart), which makes me believe it is a combination of Homey App + poor Homey wifi/networking. My guess is that it will work just fine with Homey 2023. Hopefully we’ll find out soon!

I’m having the same issue.
Homey on dedicated (2.4Ghz only) Wifi
Sometimes really unbearable.

1 Like