Homey App 3.10 instability

Hi all,

I’m experiencing app instability On iOS 13
when the app ( lost focus it does not work any more, a force close is required to get it to work again

I tried both the beta and stable branches

You better make a report to Athom Support directly. They are not reading this so it will be unnoticed and unrecorded.

I did make a report from the beta app a few days ago

But this is most likely an IOS bug and will be solved in IOS 13.3.
It is duscussed here (Dutch link)

I’m using iOS 13.2.2 on iPhone XS Max and Homey App Version and I have no problems.

Yeah, according some English sites it should have been fixed in 13.2.2 already. Here also no problems with the same specs as you.

Doe anyone have some suggestions? I’ll try to remove the app and reinstall it

I guess the answers are given :grinning:

I see the same behavior. For me the high system load is causing these instabilities. Check your average system load trough INSIGHTS and see if you have peaks higher then 1 (100%) . When the system is in sush a peak performance you will see this behavior.

The reinstall of the app did it for me, seems okay now, I still don’t understand what van cause this, wouldn’t an app be able to detect failures in data consistency