Heiman Temperature & Humidity Sensor

I have been looking for a good sensor for measuring humidity in my bathroom, so that I can start the central ventilation (BUVA) in my house during/after a shower and let it stop once the humidity is back to normal level. Initially I looked at Xiaomi sensors working with ZigBee. While they work fine and are very reponsive, I experienced connectivity issues in my house for our second bathroom at second floor. I tried extending the ZigBee range with an Ikea lightbulb - and it did help, but still the connection is not reliable enough to keep that set up - it stops about once a week and needs a reset of some kind.

So, now I am looking at a zwave solution, as this is very reliable across my house. Seeing the Heiman app developed by TedTolboom, I ordered two of them from Ali to test out as an alternative.
After install and inclusion they work fine with sending updates through for temparature, however not for humidity measures. At some points in time I see updates coming through for the temperature, however the humidity is not updated for several hours and sometimes not at all (just running it for 2 days now). The behaviour is not really predictable also, because I see humidity increase updates more frequent, and than the decreas in humidity is not received. The behaviour is the same for both devices, so I am not expecting hardware failure here.

@TedTolboom The app seems to be working okay with install (thanks btw for putting in the effort), however I hope you can have a look at way updates for the humidity measures are processed and if/when they are transmitted.
For now I have the ZigBee from Xiaomi next to the Zwave from Heiman and with this I also noted a significant slower change rate (updates arrive >5 minutes later for Heiman).

Much appreciated !

I am using Aeotec 6 in 1 sensors and they work really great

So the issue might be more related to the quality of the device and less with app?

I started thinking about it as a cheap project. 8 euro for the Xiaomi sensor and a switch for the fan. That was just for fun, now I went to little under 30 euro for a Heiman sensor, and potentially going towards 50+ Euro per sensor if this does not work either…

The reviews on robbshop are also pretty inconsistent for the Aeotech. I found Philio 2 in 1 Temperature / Humidity Sensor as another alternative. Anyone having good or bad experiences or alternative solutions?

@Oskar_Brink I would not draw that conclusion this fast…
that other sensors are (also) working great doesn’t mean that your device is of bad quality.

I didn’t add the temperature & humidity sensor myself, but will check / try to reproduce the issue tomorrow evening; ok? It can be a report parser not working ok.

That would be great. Thank you


I bought also the Heiman humidity sensor and it doesn’t update the humidity values. The temperature works and is shown at the device screen in homey app, but the humidity shows only “-”.

I checked the z-wave traffic through developer screen. I paste the results below. Can you @TedTolboom check what is wrong? I see two different measuments updated but the humidity value is not updated at the app.

[2019-10-25T20:01:53.337Z] Node[34]: Received application command for COMMAND_CLASS_SENSOR_MULTILEVEL, data: 0x0501420463
[2019-10-25T20:01:53.338Z] Node[34]: [COMMAND_CLASS_SENSOR_MULTILEVEL] {“Sensor Type (Raw)”:{“type”:“Buffer”,“data”:[1]},“Sensor Type”:“Temperature (version 1)”,“Level (Raw)”:{“type”:“Buffer”,“data”:[66]},“Level”:{“Size”:2,“Scale”:0,“Precision”:2},“Sensor Value”:{“type”:“Buffer”,“data”:[4,99]},“Sensor Value (Parsed)”:11.23}
[2019-10-25T20:01:53.364Z] Node[34]: Received application command for COMMAND_CLASS_SENSOR_MULTILEVEL, data: 0x05054218bd
[2019-10-25T20:01:53.365Z] Node[34]: [COMMAND_CLASS_SENSOR_MULTILEVEL] {“Sensor Type (Raw)”:{“type”:“Buffer”,“data”:[5]},“Level (Raw)”:{“type”:“Buffer”,“data”:[66]},“Level”:{“Size”:2,“Scale”:0,“Precision”:2},“Sensor Value”:{“type”:“Buffer”,“data”:[24,189]},“Sensor Value (Parsed)”:63.33}


After multiple pairing, unpairing and factory reset I got the Heiman humiditys sensor measurement to work. I’m not sure was it the repairing or factory reset that helped, but the issue was that the pairing wasn’t somewhat complete or made correctly.

And now the measurement type is also correct:

“Sensor Type”:“Relative humidity (version 2)”

I would like to add two more HS1HT-Z sensors but the inclusion is not successful. I receive “status_request_timeout”. When pairing is initiated (by pressing 3 times the knob), Homey is progressing like with other devices. The green led is flashing for about 30 secs.
When the process repeated (without factory resetting) following message comes: “status.already _added”. I have already tried pairing on many different ways (restart the app; plug out Homey, factory resetting the Heiman sensor, …). There were cases whan I could see new device logs on the Develpoer z-wave page ( As nodes were not responding, all deleted).
I have even excluded one of the existing sensors than restarted the app but I could not reconnect it either. I could read similar symptoms related to a smoke detector but in my case none of my new sensors shown up in the device list so far.
The only thing I have not tried is to remove the app and re install it. In this case I would loose all my related insight data and I would like to avoid it.
Homey Pro: 3.1.0; Heiman App: v1.0.6; external z-wave antenna; 20+ different z-Wave devices.

Any suggestion?

Hello! athom Homey 4.2 no settings (report threshold for reading temperature and humidity)! Z-WAVE heiman|690x388