Heatit z-trm3 configuration

Hi,

I have just upgraded my home with Heatit z-trm3 thermostats and a Homey Pro.
Homey firmware: 4.2
Z-trm3 firmware: 4.0 (have to figure out how to upgrade these also)

I have been looking at the forum for similar issues, but with 1 thread and 400 replies ranging from the first release of the app to the latest it is difficult to find similar issues. Not sure if it is possible to have multiple threads within this topic (heatit app) to differenciate between problems and make it easier to search? Anyway, my problems are as follows;

  1. Unable to re-configure the z-trm3 from the homey app
  2. One for the z-trm3’s are not updating the heating mode temperature in advanced settings
  3. A good user manual for the AF mode

Unable to re-configure the z-trm3 from the homey app
I have a floor sensor connected to all of my thermostats. It seems that some of these are positioned too close to the heating cables in the floor because the floor temperature spikes (reaches the setpoint) soon after they are turned on. This issue I’d like to solve by using the AF mode where I can use the floor sensor to protect the floor, and the internal sensor to regulate temperture in the room.
The problem: I go into the advanced settings and switch from floor mode to internal sensor mode. I also changed the “displayed temperature” from floor to internal mode. I the exit advanced settings using the “v” and it returns to settings screen with the text “changes saved”. However, nothing has changed. I go back into advanded settings the original floor mode settings are still relevant.

Do I really have to remove the z-trm3 from my system and re-integrate it to change settings?? That just seems hard.
On a side note, trying to change the mode on the z-trm3 itself also does not work

Heating mode temperature not updating in advanced mode
The device is working and changing temperatures according to “night” and “day” settings. However, the advanced mode heating temperature setting is constant on 250 (25c) regardless. Another (maybe releated) issue is that if I change the temperature setting for the z-trm3 via the app, the app shows it as “turned off” (no information displayed and I cannot change the temperature again). I have to toggle the on/off in the app for it to update information. This only happens for 1 of the 5 thermostats I have.

User manual
This is more a request then an issue.
I believe many of these issues could be resolved by a “user manual” type post on the forum related to each type of device within the Heatit family supported by this app. I guess it’s a lot of work, but I think it would make it much easier to find out how to use the app for a given device and to search for issues related to them

Lastly, I see mention of a 5 meter distance requirement betwen the Homey and the Heatit device. I assume this is only a requirement during configuration since many homes will have problems having all devices within a 5m radius of the Homey.

Thanks for your efforts in creating the app and helping me with these issues
Best regards

Kjell

Hi

AFAIK the z-trm3 is a little tricky(or picky) when including it. So for the configuration problem and temperature update problem, I would suggest you exclude/include the device at very close range. I had my homey about 1m away. And do not breathe when including :wink:

Some info

For the user manual, one can always start a topic in this forum to make a guide for it. The community is about participation, but somebody has to start, it could be you?

Hi and thanks.
I’ll try to put it close by when configuring it. I assume distance is only an issue during configuration.

As for the manual, perhaps it can :slightly_smiling_face:
Just have to learn it myself first…

Kjell

Had similiar issues with my five Heatit Z-TRM3. A couple of weeks ago two of them lost communication. After a while I lost contact with all five of them. Even some lights (Fibaro and Nexa) got issues. Tried to add them again, but often failing. Had to hold the Homey gateway 5 cm from the thermostat to add. It started communicating again, but stopped after a few hours.

I resolved the issue this way:

  1. Reset Z-Wave network in Homey (Settings - Z-Wave). All Z-Wave things will disappear…so be aware if you have a lot

  2. Started adding the Z-TRM3 by first reseting each thermostat (press middle button and down button for around 20 sec - display will show Res)

  3. Added the thermostat by having the Homey next to it (…yes, takes a lot of time as you have to wait for it to restart each time you move it…)

Still working again after a couple of days, crossing my fingers. The same with other Z-Wave equipment I have.

Not sure why they all stopped working:

Theory 1: I can see Heatit released a new version of their app (2.7.2) a couple of weeks ago. Fits with when the first thermostats lost connection, but not verified.

Theory 2: The Z-Wave mesh network somehow got broken and the thermostats and other Z-Wave things lost communication (over distance) and was no longer able to communicate with the Homey gateway.

Grateful for anyone who have more insight would share their knowledge, I am a newbie when it comes to Z-Wave.

1 Like

I noticed that Homey app was updated to 7.1.5 12 days ago. And starting then - 3 Z-TRM3s have lost contact with Homey. Although 2 of them are ‘reachable’ they do not respond. Have restarted Homey, TRM3s etc. Still nothing, You suggest resetting the Z-wave network? I have more than 20 devices, including 7 dimmers, that are in wall/ceiling fixtures. All this will have to be reset?

  • adrian
1 Like

Did you ever figure out how to update the firmware?

1 Like

Any update on how to update firmware?

Sounds frustrating to reset the Z-Wave network with so many devices, especially those wall plugs.

On rhe positive side, my Heatit thermostats and other Z-Wave stuff have now been running steady for 14 days, no issues.

And I have turned off automatic updates on both the Heatit app and Homey itself so I can monitor the forum for a week or two for issues before I do the update myself.

I still have to reset them every few days :confused:

Does anyone know if it is possible to configure a z-trm3 to be controlled by another z-trm3s internal temperature sensor? And if so, how?

I have two z-trm3 installed in the same room, but one is mounted on the outer wall and detects too low a temperature. I want the units to be controlled equally and based on the temperature recorded by the unit mounted further into the room. I experimented with associations, but havent managed to get them to behave as i want.

Doesn’t do exactly what you want, but you could achieve the same effect by using the app to group them, I guess. And have a flow that if one updates, it should update the group.

Note you should also use a logic flag to make sure that you don’t update in an infinite loop :sweat_smile:

Vthermo app might do it? Haven’t used it but seems like it has the function you need.

Other option is to make control flows to set the target temperature of the thermostat.

Thanks @peltsi51 & @Strauman. Tried both solutions but could not get them to work as i want. Ended up with using flows to turn the “slave” thermostat on/off whenever the “master” is heating/not heating. Not perfect, but good enough as a workaround…

2 Likes

Actually - I agree with @peltsi51: VThermo should be able to do this I think.

image

Hi. I am just getting starting with my Homey Pro and I only have one Z-Wave component in my system; The Z-TRM3. I have a flow that turns the Z-TRM off when the total consumption for the whole house reaches a threshold and turns it back on when the consumption is lower than this threshold minus the consumption for the floor heating. After some random time (days / hours) I lose contact (I am not able to send commands to the Z-TRM3) and need to delete and re-add the Z-trm3. Is this a known bug? Does anyone have a workaround? FW version Z-TRM3 = 4.0.771 HW version Z-TRM3 = 3. Homey-version = 7.2.1 App-version = 6.11.0.854.

BR,
Øyvin Eikeland

After some searching I found a response from heatit in the heatit app user review section about adding the device without security (When it asks for a DSK type 0 0 0 0 0 instead). I have done this now and it is working again. Lets see if it is working for more than 5 days (my previous record).

BR,
Øyvin

1 Like

Thanks for the tip, I’ve been having the same problems s you. But - where is this DSK number to be entered? I also tried finding out about updating the firmware, the only info I found through a German YouTube video was that you can send the unit to a company that would supply them themselves…