Heatit z-trm3 lost contact with Homey after 7.1.5

Starting with the latest Homey 7.1.5 update, I have now lost contact with 3 Heatiit Z-TRM3 thermostats. 2 of them are still ‘reachable’ - but they do not respond to commands. Be grateful for any advice on this. Have tried restarting both Homey and the thermostat.
Hesitant to reset Z-wave as I have more then 20 devices, including dimmers in ceiling and walls

There is a separate thread for HeatIt. HeatIt itself is more or less active in this thread. It would be better to post your questions/problems in this thread.

OK, not sure whether this is a Heatit or Homey issue. But I’ll try there as well.


I seem to have the same issue :confused:

Hi, this is an app issue that arose after Homey updated to version 7.0.0.
An update we are releasing will probably resolve this issue.

1 Like

Thank you so much for the information!

I still have this issue with my 3 ztrm3 thermostats.
Have you released the update? What is the newest version of the app?

I had to reinclude 2 of my z-trm3 and factory reset and reinclude a third one. But now they’re all working as normal.


There is an issue with S2 security on Homey. I suggest you reinclude the devices and when it asks for a dsk code you type 0 0 0 0 0 instead.

1 Like

my Z-TRM3 also lost connectivity with Homey pro at some time… probably after the Homey update to version 8.03.
trying to pair with the in-app instruction did not work… always ending with “ERR” on the thermostat.
indeed after a factory reset (thanks for that tip) of the thermostat the pairing worked again…
i had a Schwaiger zwave hub that had similar issues in the past. (after half a year it lost connectivity and never got it working after…).
my suspicion is that the heat-it z-wave implementation is not very robust…