Heatit z-trm2fx floor temperature wont show in homey


I have heatit z-trm2fx and using floor sensor. The thermostat is set up regulating with floor sensor, but the floor temperature wont show in homey, but shows on the display of the thermostats.

any tips?



I had the same problem, but also that the energy consumption never got updated, and there was no communication between heatit and homey. For me it was that it was connecting through a non-existing node, check developer.athom.com, under z-wave, to check if this is the case for you too. Only way I found to fix this, was to exclude my heat-it ztrm2fx from homey (z-wave settings), factory reset z-trm2fx, and then reinclude. The problem does however come back. I have reported this to the developer and to athom.

I had two HeatIt Z-TRM2fx installed. But when I should add the third one it cointinusly failed.

But this is how I managed eventually to add the third one.

  1. Disconnect the thrid one from Z-Wave Homey.
  2. Reset the device Z-TRM2fx
  3. Add the device Z-TRM2fx
  4. Number 1 changed to a green arrow.
  5. Add the device again now the spinning start.

Oh Yes! I have the Homey Ball/Globe just an half meter from the Z-TRM2fx. During the installation.
When it works I place the Homey to it’s original place in the house.