Heating Zone Schedule DYI


I was wonder if homey offer some schedule feature for zone heating ?
I would like to build my own heating zone with temperature sensor and zwave valve on each radiator. Then one relay at the boiler. So when one zone request heat it open the valve and send request to the boiler. Is there a way to do that easily via Flow? Or do I need to do some programming.
I not want to invest in thermostat such Nest or honeywell.

Edit: Just found interesting post

But still there is no schedule feature. I will give a try.

Kind regards,

I vaguely remember Athom have previously stated (on slack) that they would not approve an for scheduling, I read that to mean that its something they themselves would like to one day handle. But i’m just guessing.

I don’t see why you couldn’t use flows to create the same schedule I have running on my Ecobee, what you want to have a close look at is the 'Date & Time" Card, using it in the ‘and’ column you can have differnt outcomes for different times of day, days of the week, or even seasons.



Thank you very much. In the post it explain more or less hoe to do with flow. So I will give a try.
I will receive my Homey today.
I have some Qubino Relay and some Eurotronic Spirit zwave valve.

Just a bit of my story.
It is now more than 2 years I use Domoticz with Rflink no zwave. Now I would like to have all in one system. So first I took the fibaro HC Lite I use it a week set my zone my valve works pretty good. But you cant send heating demand to the boiler with the schedule program from fibaro at lease on the HC Lite. Also no LUA. I was too restricted and decide to send it back.
Now I go for Homey because of multi protocol, and ability to do lot of things. Let’s see and hope it will be successful.

Again thank you, keep you post when it’s done and working.



What I would do is the following, using the Better Logic app:

When the measured temperature is lower than the requested temperature set a variable like woonkamerwarmtenodig = true and slaapkamerwarmtenodig = true

Then in a seperate flow check if one of those variables is set to true upon a changed status (or every minute or something) and if one of those variables is true, then poke the boiler in whatever way.

This way you can prevent that if one room is at temperature, that the boiler will remain heating the other rooms if required.

The downside to your potential setup, is that you can’t use throttling. (Modern boilers with OpenTherm can ignite at 10% or 25% depending on the heating requirement). If you have a system that you can use a percentage of the boiler capacity, you could use room variables to digits. (So woonkamer = 40%, slaapkamer = 20% - You’d have to experiment what capacity is the golden middle between cost saving and comfort)


Thank you very much for the answer. AT the moment I have 3 zone, and my boiler a NEFIT does not have the opentherm. So it just fire up at 100%.

I will try something like that

But dont see how Eternity include schedule time.

Do you by any chance live close to Eindhoven?


I’m not sure what you mean by schedule time.
The valves I use are temperature aware, so what I basically do is tell the valves to go to a specific temperature.

Flow 1 - 5:
If 07:00 then set variable ‘Gewenste Temperatuur’ to 20
if 09:00 then set variable ‘Gewenste Temperatuur’ to 16

Flow 6:
If variable ‘Gewenste Temperatuur’ is changed (left column) and variable ‘Automatische thermostaat is True’ (middle column) then set thermostat to ‘Gewenste Temperatuur’

If your thermostat valve is not temperature aware, then you could look into something like:

Flow 6:
If variable ‘Gewenste Temperatuur’ is changed (left column) and ‘Gewenste Temperatuur is less than Huidige temperatuur’ (middle column), then (Fire up the boiler and do the other stuff that is required in your setup) (right column)

And no, I don’t live near Eindhoven. I live near Rotterdam. :slight_smile:

I made one, you can try here:

A quick look at the UI

1 Like

Hi Lennard,

I submitted a new version to the store a few days ago. Once that is approved I would ask you to check with that version again.

I changed the API setting the target_temperature and hope that helps. Release notes: https://homey-heating.mskg.app/releasenotes/v01-01.


Hi Markus,

I just noticed that (which I why I retracted my post :slight_smile: ) Testing with that now. I’m currently testing with release 1.1.1

So far it does spit a lot of errors, but it does work. (( errors like "Falied to set thermostat to 19 (invalid_type) )). I’m not sure when it gives that error though, as it does seem to function.

Hi Lennard,

Great :slight_smile: The errors are directly coming from the Homey API when the device is requested to set the target_temperature to a specific value. If that fails (for whatever reason) - the app tries to set the value 5 times with exponential retry time before it “complains.” If you are refering to the output in the log, that’s expected for the retries. If you are talking about the Homescreen (notifications), it means it didn’t work (from the persepctive of the API).

I any case, I’m interested in the logs - started a chat with you on Slack.


Hi Markus,

Thanks for your time on Slack.

Everything works perfect in the 1.1.1 version!!
Very easy to set up and it replaces 30+ flows for me!



I’m back, after my first attempt I decide to send back my Homey. Yesterday I check and saw the V2 and nice heating zone schedule available. I decide then to get a new homey. I have already install some of my 433Mhz devices. Later next week will try definitely your app Markus. Thank you.