Google home sync issue

Hi All,

I’ve got a sync issue to google home. I’ve search the forum and tried everything I’ve seen in different posts however with no luck, it actually became worse. Maybe someone else experienced the same or can give me some suggestions.

I discovered the issue when I configured a new flow and google which was synced to google because I could configure it in a routine, however google home was responding with that it could not connect to homey. However I can still control my devices in there and also execute routines with other older flows. So I did the following based on posts I found

  • Check google sync on homey app. It was enable I disabled it and reeabled it again, no luck
  • Then I reconnected the account, still no luck. The nr of devices seems also way off to me, no updates still the same issue
  • Then I unlinked my account somehow the devices were still visible in google home, strange…
  • Then I tried to link it again. Now it prompts: “No devices were found in your homey account” , devices are still in there and I’m able to control them but no sync and no homey configured/linked
  • Then I created a new home, no devices visible except my google home devices
  • Then I tried to link homey to my new home, same message "No devices were found in your homey account

Homey is now also not listed anymore in linked services on google home after I got the message “No devices were found in your homey account” I’ve tried to add the account 10 times but same message and not linked

Anyone have any suggestions what I can try?



First thing i’d do is unlink google and homey completely.
Also, make sure you’re logged in on the account your homey is set up on
Syncing devices I do by asking google to “sync my devices”
Everything is managed by homey on my end.
No other providers linked to my hubs.

Sometimes my hub does respond that it cannot reach homey but executes the action as requested anyways.

Also you may try to RESET -

I have the same issue. Added some devices in Homey app and then tried to sync with Google. No new devices found anymore.
Looks like the syncing is broken…

And you do have enabled sync to Google in the Homey app settings, right? It’s turning off sometimes randomly…

Thanks for looking into this. The suggestions i all tried like i described in my message. Sync enabled, tried to completly unlink and link google which made it worse.

I’m going to look into the reset suggestion

I can’t find any info on the RESET in the given link.
Also, don’t get a “sync” toggle switch in the Homey app.

Enabling synchronization with Google (optional)

Additionally, Homey can synchronize the live status, name, and zone of your devices with Google Home. This might improve the speed of certain voice commands.

To better protect your privacy, this functionality must be manually enabled in the Homey app.

  1. In the Homey app, navigate to More (...)SettingsGoogle Assistant .
  2. Enable synchronization by tapping the switch at the bottom of the screen.

Note: By synchronizing your device data to Google, you are subject to Google’s Privacy Policy.

Note: When synchronization is not enabled, newly added devices might not appear in the Google Home app. You can synchronize manually by saying “Hey Google, sync devices”.

Hi @Sharkys your link is not point to any reset guide. I tried to search it but seems to be finding only pages home to link to home assistant. I cannto find an option to completely reset my google home assistant configuration. Any has experience with that?

Hi All,

After some troubleshooting I found it myself. There was another device in play. My wife was also connect to google and some how her account still had the connect to homey therefor no new devices were found because her account already got that.

To reset you home assistant app you can clear the cache in the android settings of your app

Thanks all who looked into this


1 Like

yep i get exactly the same thing, im working with the support team as well on this, ill try clearing all settings again… again
Edit: tried

  • clearing the google home cache (removed app and reinstalled too)
  • removed all family from home
  • left home, and removed it totally
  • made a new home with just my acc in it, and tried to re add homey… fail (sonos and spotify etc all added back no issues)

Okay, sure theres no other phone connected to your home? Wif, kids, brother, friend?

If do disconnect everything from every device. Then try again.

If everything fails try this as oast resort.

Create new google account and couple it to you homey.

Else, backup homey, and reset that as well and recover config

thanks for the ideas…
its a lot of mucking about for something that was working fine, and nothing changed on my side, and seems others have had related issues about the same time.
Tried a brand new google acc with nothing else linked or connected and still get the same error after authenticating on

just as an update about 2 weeks later, google just magically reconnected, the team at Athom couldn’t shed any light as to why

1 Like