Fritz!Box no local connection issue - solved

Hello,

There is an issue with the Fritz!Box which causes that you can’t connect Homey local (ssl) by a webapp like homeydash. DNS rebinding protection does not allow homeylocal.com to point to your local homey IP.

To see if your connection is over the cloud or local go to https://developer.athom.com/tools/system

To solve this issue you need first the IP of your Homey. That’s for example 192.168.178.123
then you go into your Fritz!Box and enable “advanced view”.
Next go to Home Network -> Network and on the top menu on Network setting. On the bottom of the page you should find a box which called something like “DNS-Rebind-Protection”. There you have to enter the domain which homey uses for local connection. It starts with your IP which is seperated with dashes instead of dots followed with .homey.homeylocal.com In our example it would be 192-168-178-123.homey.homeylocal.com Dont forget to click on apply.

If it was successfull you should see now on https://developer.athom.com/tools/system Connection Local (Secure). Maybe you need to clear the cache first.

Hope this was helpful for some users.

2 Likes

I think I have the same issue and it started when I got Synology DSM 7 on my NAS and decided to start using a local DNS …
Unfortunately my ZIGGO connect modem doesn’t have a DNS-REbind-Protection option :frowning:

But at least I have now something to investigate further!

You should be able to find out if this issue is causing your problems by trying to resolve a hostname like 127-0-0-1.homey.homeylocal.com; it should resolve to 127.0.0.1, if it doesn’t (or it returns an error), DNS rebind protection is probably active.


Correct the query was for 192.168.0.240 - which is the reserved ip in the Synology DHCP server for Homey’s MAC-address.
Out of curiousity I did a portscan on my homey and port 53 was open, don’t know if that matters…

Anyway I did some experimenting with DNS and my desktop is now able to find homey using the 192-168-0-240.homey.homeylocal.com name…

I’ll repeat the recovery setup later - hope this works…

BTW but homey is still reported by athom as being offline, just like the app… only portscan and ping seems to work fine.

Homey runs its own DNS server, for whatever reason… :thinking:

If I use nslookup and use 192.168.0.240 as the dns server I only get timeouts…

Yes, it’s only for local (software running on Homey) use. Why they chose to expose the port is beyond me.